1

Anyone knows how can I check/test my 2d acceleration? See if it's on/off and working correctly and as efficient as it should?

I have SIS 771/671 on Zorin OS 8 Lite. I believe the resolution should be better (it's 1024x768 right now and it looks a bit stretched horizontaly I assume 1024x1800 could look fine) and I feel video could go more smoothly and also I see some horizontal lines on the screen when playing movies.

So basically I think that the video driver is still not proper here. I found this instruction here at comment #230: sis drivers discussion

I have a patch here :

https://www.archlinux.org/packages/?name=xf86-video-sisimedia

btw the patch is for 13.04 - will it also work or be needed for 13.10?

Otherwise is there any other recommended lite distro on which SIS 771/671 could work fine and with acceleration ON?

0

I had a notebook with this very same card back when Debian Squeeze was fresh. I know this is super mad old and may not work on your case, but from every method I tried out there (dozens, just to keep in mind), only one that worked was this (for me and others on the community too).

It also will give a 1280x800 resolution, but will kill the VGA port (if it works).

First of all check your card (just to make sure haha).

$ lspci | grep VGA

It must show something like: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

If that's right, proceed downloading the file https://www.dropbox.com/s/6j58k0cctxix2q4/Driver-2d-Sis671-771-Debian6.tar.gz?dl=0

The file is in my dropbox for 4 years now, I think I won't delete it soon.

Decompress it using $ tar -zxvf Driver-2d-Sis671-771-Debian6.tar.gz

After that you'll need root permissions to copy the xorg.conf file to /etc/X11/ and the .la and .so files into /usr/libs/xorg/modules/drivers .

After that reboot your notebook and try setting the new resolution.

This used to work fine on Debian and Ubuntu back in 2011. Now I don't really now, but everybody who tried this method reported it as working those days.

If it fails, sorry :( I tried my best.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.