1

I install gnome software centre by : sudo yum install gnome-software

but when i open software centre it shows nothing enter image description here

NOTE : I am Using Fedora 20 Cinnamon DE

1 Answer 1

1

I'm running F20 as well and your version looks a bit different than mine.

    ss1

I would suggest un-installing it and trying to re-install. If that doesn't work then it's likely that the application maintains configuration info, perhaps in the $HOME/.config directory. I'd attempt to remove any files/directories related to this app and try running it with a clean slate.

Tracking down apps caches

You can use this trick to find out what directories gnome-software is accessing using strace.

$ strace -s 2000 -o gnome-software.log gnome-software 

You can then grep through the resulting log file, gnome-software.log to see what locations the app's accessing. Typically with GNOME apps, there are config files under $HOME/.config.

5
  • @Slim Thanks ..worked for me...but Why there is no minimize and Progress bar in it ??? Commented Oct 28, 2014 at 15:27
  • @AshutoshKale - that seems to be the direction that GNOME 3.x is moving. I find it extremely annoying too. I'm also using Cinnamon 8-)
    – slm
    Commented Oct 28, 2014 at 15:42
  • yum install gnome-tweak-tool (or find it in Software Center) will allow you to enable the minimize button (and lots of other tweaks too). Commented Oct 28, 2014 at 16:04
  • @garethTheRed - thanks I use that too. Forgot to mention it, I generally setup my laptop/destkop the way I want and then sit on it for long periods of time until either the hardware dies or I have to upgrade to a newer version of Fedora 8-). I used that tool + a whole host of plugins to Cinnamon back in June/July and have now forgotten about them.
    – slm
    Commented Oct 28, 2014 at 16:15
  • I had the same problem, the config file is at ~/.local/share/gnome-software. However the problem was with my repo data: repodata ***** was not complete: Unknown checksum type "md5" for /var/cache/PackageKit/metadata/****/repodata/filelists.xml.gz. So check your yum! funny strace did not show anything about accessing filelists.xml.gz. Running sudo gnome-software did it for me. it prints the ugly org.gnome.Software:3891): Gs-WARN1 messages directly to terminal. Hope this helps someone.
    – hkoosha
    Commented Dec 21, 2014 at 9:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .