I'm currently using Ubuntu 11.04 and I'm running into a really annoying issue while developing for web. I'm rather new to Ubuntu, coming from FreeBSD where I never encountered an issue like this, so I'm hoping that someone else here has and can point me in the right direction.

I do all development in vim (console). Whenever a browser (in this case, either chromium or firefox) feels that it needs to log some error or assert, it dumps it out to all active consoles. Sometimes showing up over my work, sometimes not. Forcing a full screen refresh (either through changing the console to full screen or minimizing/maximizing) gets rid of the text, but it's still annoying to have to do any time I encounter this problem.

Is there a way to disable either of these browsers from logging like this? Is there a compiler flag or is it something that I can set through browser options or command line parameters?

  • That's weird. Many GUI applications spam their standard error stream, but that should only go to a particular log file (~/.xsession-errors IIRC) or to the terminal where you launched the application from. Only important kernel mesages should go to all consoles. Please post a sample of these messages. Jul 11, 2011 at 13:10

2 Answers 2


Sounds like you are starting your browsers from the command line and sending them to the background. Perhaps running a command such as ($ is the command prompt)

$ firefox &

In that case, even though the process is being sent to the background it is still writing any issues to stderr (or, in other words your active console). If that is the case all you need to do is redirect the output by modifying your command to look something like

$ firefox &> /dev/null &

That command will redirect all output to /dev/null. You can change that to a file if you would rather capture the output. Check out this article for more options.

  • Makes total sense (can't believe I didn't think of it :P). I'll try 'er out once I get home and will accept the answer if it works (which it obviously should). And yes you're right.. I'm starting the browsers with $ firefox &. Jul 11, 2011 at 20:17

You can try this command to discard all the logs

$ firefox > /dev/null 2> /dev/null &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.