7

I need to use the acpi_listen command. It wasn't installed so I did:

pacman -S acpid

Then when I run the command acpi_listen I get:

acpi_listen: can't open socket /var/run/acpid.socket: No such file or directory

I checked the in /var/run and the file does not exist. If I do a ps -ef | grep acpi, it outputs:

[acpi_thermal_pm]
[ktpacpid]

What can I do?

9

In archlinux, this will make it work: systemctl start acpid.service

  • 1
    This should be marked as accepted! :) – Alfabravo Feb 14 '17 at 20:07
  • It does not make it work. At least a hint to status and error message should be given to debug the situation or at least give it up – JackGrinningCat Sep 7 '18 at 18:28
  • That's the systemd way, so ArchLinux is "Poetterized" as well? – Csaba Toth Mar 3 at 18:47
0

For me the acpid.service was already running. I use Debian 9 (stretch) so this might not be the case for everybody.

/var/run/acpid.socket is the default location. Checking the systemd status of acpid.socket reveals where the actual socket file being used is located.

$ systemctl status acpid.socket 
● acpid.socket - ACPID Listen Socket
   Loaded: loaded (/lib/systemd/system/acpid.socket; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-03-25 18:33:04 CET; 41min ago
   Listen: /run/acpid.socket (Stream)

Just create a symlink to the default socket location and you're good to go:

sudo ln -s /run/acpid.socket /var/run/acpid.socket

Alternatively, specify which socket you want to use:

acpi_listen -s /run/acpid.socket

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.