I installed Kali Linux on my Sony Vaio laptop (model number SVF142C1WW), but I had no wireless out of the box. Ethernet works fine, and I can connect to wireless networks normally from Windows running on the same machine.

I found this video on Google which suggested I install the compatible wireless driver. I downloaded it from kernel.org, extracted it to ~/Desktop and ran the following commands:

$ cd desktop
$ cd filenameofthatextracted folder
$ make unload
$ make load

After these commands, my wireless NIC seems to be recognized (see iwconfig output below), but I can't see any available wireless networks. Also, the driver disappears after restarting, and I have to run the commands again and reinstall to get the NIC to show up in iwconfig again.

Relevant information:

root@Light:~# iwconfig

wlan1     IEEE 802.11abgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

hwsim0    no wireless extensions.


$ lspci -vq
07: 00. 0 Network controller: Broadcom Corporation BCM43142 802. 11b/g/n (rev 01)
    Subsystem: Foxconn International, Inc. Device e071
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at 90700000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Vendor Specific Information: Len=78 <? >
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-87-ff-ff-7c-34-23
    Capabilities: [16c] Power Budgeting <? >
    Kernel driver in use: bcma-pci-bridg

I found one more thing, and now I'm totally confused...

See, while installing Kali Linux this is the menu you get in the beginning:

Kali - boot Non Persistent Mode
Kali - Boot Persistent
Kali - Failsafe
Kali Forensics - No Drive or Swap Mount
Kali Graphical install
Kali Text install

I went into the option Kali Graphical Install to install Kali Linux.

I believed to run live Kali, and I have to go in Kali - Boot Persistent. I went into that, and I got Kali desktop. And I found out that Wi-Fi drivers were perfectly fine and they were working well. I can connect to any Wi-Fi connections and all Wi-Fi connections were showing.

What is this?

And there is one more thing. While installing Kali Linux, inbetween I got an error message saying the following...

Some of your hardware needs non-free firmware files to
operate. The firmware can be loaded from removable media
such as a USB stick or floppy.

The missing firmware files are: rtl_nic/rtl8168e3.fw

But after I ran some update and upgrade commands, it is present in /lib/firmware.

  • 1
    Please edit your question and show the output of iwconfig also, please show the output of ifconfig after following whatever that video suggested. – terdon Oct 27 '14 at 13:36
  • @terdon i edited the question, please help – Anurag Kumar Oct 27 '14 at 14:45
  • Thanks for the edit. See here for help on formatting your posts. You also need to tell us the model of your wireless card. Please add the output of lspci -nn | grep work to your question. – terdon Oct 27 '14 at 15:20
  • @terdon hello, i edited the post, hope this time i edited it the right way. sorry for trouble. can u please look into the problem and tell me whats wrong – Anurag Kumar Oct 27 '14 at 17:47
  • Thanks, you don't need to use HTML tags though, read the page I linked to. Also, you need to show us everything. Where did you download this "26 june 2010.p.tar.bz file" from? What is it? How did you reinstall the compat-wireless package? – terdon Oct 27 '14 at 18:12

You could try

# apt-get install firmware-iwlwifi
# modprobe -r iwlwifi; modprobe iwlwifi
| improve this answer | |

Try installing firmware-linux by sudo apt install firmware-linux this solved my problem in debian while i was using some Chinese WiFi dongle.

It will automatically install other firmware binaries.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.