81

During linux installation I selected "minimal" option:

enter image description here

When I went to run the nslookup command to look up an IP address I got the error message nslookup: command not found as shown in the example below.

$ nslookup www.google.com
bash: nslookup: command not found
1
  • 5
    Have you tried installing the bind-utils package, which includes the nslookup binary?
    – Wieland
    Oct 25 '14 at 16:26
159

The minimal install likely did not come with the bind-utils package, which I believe contains nslookup.

You can install bind-utils with:

sudo yum install bind-utils

In general, you can search for what package provides a command using the yum provides command:

sudo yum provides '*bin/nslookup'
4
  • 9
    Or if you don't know where the command should live, */nslookup. Oct 25 '14 at 16:48
  • I get package bind-utils not found
    – Black
    Jun 3 '16 at 6:30
  • 7
    @Black If you are using ubuntu, use apt-get install dnsutils -y instead.
    – cizixs
    Mar 28 '17 at 9:40
  • Also for Arch dnsutils
    – JoKeR
    Jan 28 '19 at 13:27
18

For those using DEBIAN, the package to use is dnsutils and the installation process should be, initiated with:

sudo apt-get install dnsutils -y

According to other users it is the same for Ubuntu

Not the answer you're looking for? Browse other questions tagged or ask your own question.