My computer should be able to run Ubuntu (11.04) without breaking a sweat:

  • CPU: 2.00Ghz Core i7-2630QM
  • RAM: 8Gb DDR3-1333
  • HDD: 60Gb SSD
  • GPU: 1Gb AMD HD 6570M
  • Swap: 2.7Gb

However, opening folders can take around a second, scrolling and opening new tabs in the browser is clunky, dragging windows is choppy - in short it's just plain slow. Was there something I could've messed up when installing and configuring Ubuntu? I have a feeling it's the graphics driver since, even under heavy usage, system monitor shows the swap never gets touched.

Here's the driver I'm using:

ATI/AMD proprietary FGLRX graphics driver


I think your speculation about video drivers is correct. You probably running some generic VESA driver or similarly crippled-but-works-on-anything type basic driver.

You're going to want to turn on access to the restricted drivers repository in Ubuntu. You should find some better video drivers in there.

  • I posted a screenshot of the driver I'm using. I'll try and get a better one and see what happens. – Jackson Jul 10 '11 at 22:37
  • @JacksonWalters You're already running the proprietary driver, which is supposedly faster. But it's worth trying the free driver, just in case (it might even turn out to be faster for 2D but slower for 3D or something). – Gilles 'SO- stop being evil' Jul 10 '11 at 23:09
  • I went and got this driver and it seems to be working much better now. However, after I first installed it the screen froze a couple times for a few seconds, but now it seems to be running smoothly. Thanks! For future reference, how do I turn on the restricted drivers repo? – Jackson Jul 11 '11 at 2:57
  • @Jackson You already have the restricted drivers repository, that's where your fglrx driver was from. The driver you got from AMD is the same driver (Catalyst is the new name), but a more recent version. – Gilles 'SO- stop being evil' Jul 11 '11 at 13:33

I have 10.04LTS on my Lenovo Y560P and gathered enough information to come up with this scheme: Edit your xorg.conf file in your etc/X11 directory with your favorite editor. Use these settings (basically copy and paste this whole thing) These setting will give you the 1366x768 at 60Hz(looks perfect). My video performance is good but not great, there are some tearing problems with fullscreen video, but I have this issue on other laptops with Ubuntu, the performance just isn't as good as Windows.

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"


Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth    24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes "1366x768_60.00"

Section "Module"
    Load    "glx"

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Option        "UseFastTLS" "1"
    BusID       "PCI:1:0:0"
    Driver  "fglrx"
  • Nice answer. I wonder if it still applies to a newer version of Ubuntu though. I have had some surprises when I went from 10.04 to 12.04. – vgoff Nov 12 '12 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.