1

I use Gentoo/Linux. Because of some reasons, I want to set the resolution of the console. So I rewrite grub file.

GRUB_GFXMODE=1366x768
GRUB_GFXPAFLOAD_LINUX=1366x768

But it isn't run.When I load the system, it is in silence. If I change the value, I can load the system, but nothing changes. Then I use the uveseafb. Although I compile the kernel, there isn't has a uveseafb. I'm sure that I have chosen the options and had v86d and klibc.

What can I do to get this to work? In Ubuntu, I edit grub and initramfs-tools to do it. But in gentoo, I didn't do it.

  • I'm guessing you did it already, but don't forget to check whether this resolution is available by running vbeinfo in the GRUB console. – John WH Smith Oct 25 '14 at 7:00
  • I have checked it by vbeinfo. And I am sure the seting is true. – Vonfry Oct 25 '14 at 14:10
0

It looks like you update the file /etc/default/grub without running update-grub afterwards (in my Ubuntu 12.04 that is explained at the top of that file).

Only after running update-grub are these parameters copied in their appropriate command lines in the Grub menu (/boot/grub/grub.cfg)

Additionally you should take care, in case you have multiple linux installations, that changing anything has no effect unless you edit the defaults and run update-grub on the installation your computer boots from. I.e. the one that the latest grub-install with your boot drive as target was run from.

  • I have done it but it also can't run. – Vonfry Oct 25 '14 at 14:11
  • @论极语易-Vonfry Can you add the commands and output of your actual commands to your original question? And if your username doesn't start with ASCII, it is extremely difficult to answer any comments you write for people that don't know how to reply starting with @论. So you might want to change that to Vontry-论极语易 – Anthon Oct 25 '14 at 14:17
0

You need to set the VGA console mode in /etc/default/grub add or change the value of the option vga=xxx to fir your needs.

An example for a resoultion of 1024x768 pixels and 24bit colour depth:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=792"

To apply this change you have to use sudo or su to root. Once done run:

sudo update-grub

Here is a list:


Colours: 256 (8 bits)

  • 769 [ 640x480 ]
  • 771 [ 800x600 ]
  • 773 [ 1024x768 ]
  • 775 [ 1280x104 ]

Colours: 32K (15 bits)

  • 784 [ 640x480 ]
  • 787 [ 800x600 ]
  • 790 [ 1024x768 ]
  • 793 [ 1280x1024 ]

Colours: 65K (16 bits)

  • 785 [ 640x480 ]
  • 788 [ 800x600 ]
  • 791 [ 1024x768 ]
  • 794 [ 1280x1024 ]
  • 834 [ 1400x1050 ]
  • 884 [ 1600x1200 ]

Colours: 16M (24 bits)

  • 786 [ 640x480 ]
  • 789 [ 800x600 ]
  • 792 [ 1024x768 ]
  • 795 [ 1280x1024 ]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.