0

I'm using Arch Linux. Before Arch, I was using Kubuntu. I have a Intel i7 processor with 7200 RPM hard drive. When I'm installing software (not from package managers, but a big proprietary one such as Xilinx software), the cursor is completely laggy and unusable.

Under Windows, even though the computer could be sluggish sometimes, it never freezes the cursor until completion.

I think this is due to interrupt order.

The question is how can I change the interrupt of the touchpad? If it is not interrupt, what can be the cause?

1

I do not believe this has anything to do with interrupts or their order. Rather you could try setting the nice value so that not all of the system's resources can be strictly used by the installation process of Xilinx. When invoking processes you can specify how "nice" or "not nice" they should be to other processes on the system using the nice command.

Using nice

excerpt nice man page

Run COMMAND with an adjusted niceness, which affects process scheduling. With no COMMAND, print the current niceness. Niceness values range from -20 (most favorable to the process) to 19 (least favorable to the process).

This is saying that if you want your process to be more aggressive than the other processes and take all your system's resources, then set the nice value closer to -20. If you want your process to be nice, and let other processes have the resources before itself, then set the nice value to 19.

So you could try running the installer with say:

$ nice -10 <install cmd>

This would force the installer to be "nicer", setting its nice value to 10, and less aggressive about taking all of your system's resources.

NOTE: This would make it more aggressive:

$ sudo --19 <install cmd>

You can see a processes nice value like so, using ps:

$ ps -eafl | head -10
F S UID        PID  PPID  C PRI  NI ADDR SZ WCHAN  STIME TTY          TIME CMD
4 S root         1     0  0  80   0 - 12785 ep_pol Sep17 ?        00:01:15 /usr/lib/systemd/systemd --switched-root --system --deserialize 20
1 S root         2     0  0  80   0 -     0 kthrea Sep17 ?        00:00:03 [kthreadd]
1 S root         3     2  0  80   0 -     0 smpboo Sep17 ?        00:00:50 [ksoftirqd/0]
1 S root         5     2  0  60 -20 -     0 worker Sep17 ?        00:00:00 [kworker/0:0H]
1 S root         7     2  0  80   0 -     0 rcu_gp Sep17 ?        00:15:55 [rcu_sched]
1 S root         8     2  0  80   0 -     0 rcu_gp Sep17 ?        00:00:00 [rcu_bh]
1 S root         9     2  0 -40   - -     0 smpboo Sep17 ?        00:00:51 [migration/0]
5 S root        10     2  0 -40   - -     0 smpboo Sep17 ?        00:00:03 [watchdog/0]
5 S root        11     2  0 -40   - -     0 smpboo Sep17 ?        00:00:05 [watchdog/1]

NOTE: The above column, NI, is each process's nice value. By default, processes typically have it set to 0, when it's unspecified.

Using renice

To can also change a running process's nice value using the command, renice.

Example

Say I have this process running at nice = 10.

$ nice -10 sleep 2000 &
$ ps -eafl | grep "[s]leep"
0 S saml     19675 14949  0  90  10 - 26973 hrtime 03:26 pts/0    00:00:00 sleep 2000

Now renice it to 15.

$ renice -n 15 -p 19675
19675 (process ID) old priority 10, new priority 15
$ ps -eafl | grep "[s]leep"
0 S saml     19675 14949  0  95  15 - 26973 hrtime 03:26 pts/0    00:00:00 sleep 2000
  • Thanks for a great and explanatory answer. I will give it a try and let you know! – user1754665 Oct 25 '14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.