5

On my machine, i have power savings disable on the BIOS. When I run Ubuntu on this machine, the CPU's are running maximum at 2100 MHz.

However, when I'm running CentOS 7, even with the scaling governor set to "performance", the CPU's are not running full at 2100 MHz.

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
performance
performance
performance
performance

grep -i mhz /proc/cpuinfo
cpu MHz         : 1688.285
cpu MHz         : 2058.656
cpu MHz         : 1622.988
cpu MHz         : 2070.632

My application is a network processing application, so the CPU clock difference is resulting a performance difference.

I do not have cpuspeed,powerd, or any other power regulating services running.

So my question is, is this expected behavior given the cpupower is set to "perform"? It seems CentOS is override the BIOS setting.

When I boot to Ubuntu, it just takes the BIOS settings and all the CPU's are running max.

2
0

The solution i've found is to disable intel pstate in grub

0

With Centos/redhat I highly recommend using the tuned daemon to manage power states. You can install it with yum install tuned It sounds like you want:

tuned-adm profile latency-performance 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.