3

I'm trying to install pip to install BeatutifulSoup4 against python3.3. Linux Mint 16.

[127]manuel@manuel-X202E:~ > pip3.2 install beautifulsoup4
No command 'pip3.2' found, did you mean:
 Command 'pip-3.2' from package 'python3-pip' (universe)
 pip3.2: command not found
---------------------
[100]manuel@manuel-X202E:~ > sudo apt-get install python3-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-pip is already the newest version.
----------------------
manuel@manuel-X202E:~ > pip-3.2 install beautifulsoup4
The program 'pip-3.2' is currently not installed. You can install it by typing:
sudo apt-get install python3-pip

so, the package is installed but it's not detected (I tried to restart OS)


I also tried:

 sudo apt-get purge python3-pip 
 sudo apt-get install python3-pip 
 sudo apt-get update
 sudo apt-get check

As well as

 sudo apt-get purge python3-pip 
 (reinstall via Synaptic)

EDIT: I finally solved (using dpkg) . The problem was that I should use

 pip3

instead of

pip3-2
1
  • List the files in the package. This is usually a reliable indication this those files are present on your system, but you can always check if you want to. Check for /usr/bin/pip-3.2. I just installed this on my system, and that file is listed, and pip-3.2 runs. Use dpkg -L python3-pip. Oct 24 '14 at 9:29
3

From your question I think, your problem is just a typo - the correct command is pip-3.2, not just pip3.2.

EDIT: Ok then, if the typo wasn't the main bad guy, let's try something else...

1) Uninstall python3-pip

sudo apt-get purge python3-pip

2) Clean everything :-)

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get remove
sudo apt-get autoremove

3) Install python3-pip, update your package list and check dependencies

sudo apt-get install python3-pip
sudo apt-get update
sudo apt-get check

4) If this does not work, try to reinstall it using Synaptic

5) If you still had no luck, try

dpkg -L python3-pip

and look for files located in /usr/bin if there isn't other launchable file instead of pip-3.2

4
  • it's true that it is pip-3.2 . However it doesn't work anyway (please see my updated answer).
    – dragonmnl
    Oct 24 '14 at 8:40
  • I just tried both. No way the problem is solved. I also checked very carefully the commands
    – dragonmnl
    Oct 24 '14 at 9:00
  • I finally found (by using dpkg) that I should use "pip3" (instead of pip-3.2) which worked. thank you!
    – dragonmnl
    Oct 24 '14 at 9:29
  • You're welcome! And here we see, that we can't fully trust Error messages :-) Add please this solution to your question, to make it easier for somebody new to find ;-)
    – Eenoku
    Oct 24 '14 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.