0

This question already has an answer here:

I have an issue for which the work around would be to start the application in X instead of headless. How do I make sure the app is executed on the desktop, even if I run the command from a remote ssh connection.

marked as duplicate by Gilles, jasonwryan, Anthon, jimmij, slm Oct 22 '14 at 17:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You can use the DISPLAY environment variable to start a GUI program on the remote computer. However, it is not shown to you, but rather opens on the active X-session with address :0, which is the default for the first X-session. To enable, use

export DISPLAY=:0

For more information, see this post.


If you also want to see it, use ssh -X to log on that computer. For more information, see this relevant post.

Not the answer you're looking for? Browse other questions tagged or ask your own question.