3

Because OpenBSD 5.5 does not appear to support moderately newer Nvidia cards (mine is a GT 610), I am using the vesa X.Org driver. Problem with vesa is that the displayed image is shrunken and doesn't expand completely to the monitor's full area of view.

Are there any tricks or command-line things I can try to get this shrunken vesa-mode video expanded fully?

EDIT: My display has a native resolution of 1920x1080 and X is also running at this same resolution.

  • 1
    What is the resolution of the display and what resolution is X using? xrandr -q should give this info. – Cristian Ciupitu Oct 22 '14 at 4:18
  • Thank you Cristian. I have edited my question to include that information. – Will B Oct 22 '14 at 15:54
  • nomodeset in grub command line – user92226 Nov 20 '14 at 11:09
1

I had the same problem. Very hard sometimes with the nVidia cards to get the resolution right by futzing directly with xorg so I like to use arandr for this kind of thing. (This is one of the few times that I find the GUI stuff better then the command line approach.)

pkg_info tells us about arandr:

# pkg_info -d arandr
Information for inst:arandr-0.1.7.1

Description:
RandR is designed to provide a simple visual front end for XRandR.
Relative monitor positions are shown graphically and can be changed in a
drag-and-drop way.

 Maintainer: Edd Barrett <edd@openbsd.org>
WWW: http://christian.amsuess.com/tools/arandr/

You can do all the same stuff with arandr that you do with xrandr but I find it a bit more useful to use arandr when dealing with a couple of monitors but that's another story.

So install and use arandr to setup your display the way you like.

When you fire up arandr set your resolution under 'Outputs->VGA->Resolution. You should see your different choices xorg is offering for that card and probably VESA will show up rather than VGA. Then use the 'save as' button to export these settings as a script. Usually I dump that script somewhere like ~/.screenlayout/fullscreen.sh then invoke that script somewhere in my .xinitrc with:

~/.screenlayout/fullscreen.sh &

and then when I fire up X the resolution I want is in place. If I'm feeling really adventurous I go in and modify xorg.conf afterwards but I've been lazy lately and don't muck with that much.

| improve this answer | |
  • Thanks for your answer. Because I'm no longer using OpenBSD, I'll go ahead and mark yours as the answer. Thanks again! :) – Will B Dec 11 '14 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.