3

I'm using Ubuntu 12.04 (I think it's desktop...) and running vncserver to connect to it remotely. I can successfully set the resolution if I use the -geometry flag when starting the server, but I can't get it to change the default so I don't have to set the flag every time. The manual suggests to use the $HOME/.vnc/xstartup file so I made the following change:

#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-terminal-emulator -geometry 1400x850 -ls -title "$VNCDESKTOP Desktop" &

As you can see I tried to make the default '1400x850', a resolution which worked just fine when supplied by the command line. I've even tried setting this resolution in some other files which were the solutions on other OS's, but that didn't work either.

This should be a fairly straightforward thing, what is going wrong here? Does it have something to do with desktop versus server edition? Or my X configuration?

5

$HOME/.vnc/xstartup is for the X desktop running in the server, not for the server itself. You need to create a $HOME/.vncrc file with:

$geometry = "1400x850";

in it. You have some documentation in:

/usr/share/doc/vnc4server/examples/vnc.conf.gz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.