0

I was having some problems with my laptop (asked a related question yesterday: http://elementaryos.org/answers/after-locking-the-computer-screens-look-all-messed-up) regarding some dual-screen issues. This morning my laptop fan was working at full speed. Looking for some help I found a Q&A that made some sense (I thought): http://elementaryos.org/answers/luna-running-hot-on-my-laptop-1 , so I followed the instructions:

  1. Did this:

    sudo apt-get install linux-generic-lts-raring
    
  2. Then this:

    wget http://launchpadlibrarian.net/121675171/fixplymouth
    chmod +x fixplymouth
    ./fixplymouth
    

After rebooting, my dual-screen (which used to work fine) stopped working, having this error message when I tried to change second monitor settings:

"required virtual size does not fit available size: requested=(...), minimum=(...), maximum=(...)"

I tried installing AMD Catalyst drivers for my GPU (which apparently went fine, but at the end it said that something went wrong) and when I tried to reboot, I could not get to the desktop anymore: I just get a black screen with the keyboard cursor blinking on the top left corner of the screen.

Any ideas on how to solve this (if there is something I can do :( )?

  • 1
    Can you still switch to a terminal using Ctrl+Alt+F1? It would be nice to have X11's error log (grep EE /var/log/Xorg*.log). – John WH Smith Oct 21 '14 at 8:41
  • I couldn't, but I tried again and now I can (I even got the OS logo on screen). On Ctrl+Alt+F7 I have a lot of [OK], the last one being: Stopping Userspace bootsplash [OK]; but it stays there (cursor blinking). Grepping that I have some error: /Xorg.0.log: (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. Xorg.0.log: (EE) fglrx(0): Failed to map FB memory Xorg.0.log: (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9. Xorg.1.log: (EE) Failed to load module fglrx (module does not exist, 0) – makeMonday Oct 21 '14 at 8:55
1

Finally I got to fix one of my problems. I can see my desktop now the same way I had it before installing the ATI drivers. Did it by:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get remove --purge fglrx

Found this solution here. Apparently, having elementary os drivers and ATI drivers gave me some conflict so I had to uninstall one of them.

Thanks to @JohnWHSmith for leading me to the solution ;)

  • 1
    fglrx is the proprietary driver. You were probably trying to install the open-source one, and they don't do well together :) – John WH Smith Oct 22 '14 at 18:05
  • Right! Actually, it was the other way around. I was trying to install the proprietary driver for fixing something and I ended up messing everything. Thanks ;) – makeMonday Oct 30 '14 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.