This is a follow up to my previous question about Debian support for Linksys Wusb600n. I have tried running the Ubunut/Xubuntu LiveCDs and the WiFi does not come up.

The Gnome Network Manager menu informs me that my wireless network "device is not ready (firmware missing)" as shown here:

Network connections on Xubuntu

Where can I find Ubuntu packages with the firmware and drivers needed to support the Linksys Wusb600n USB WiFi stick?

  • Do you have the firmware-linux-nonfree package installed?
    – bahamat
    Commented Jul 9, 2011 at 17:26
  • @bahamat I guess: no. I just did simple install of Ubuntu 11.04. How can I install it without network connection? Maybe, I can get needed files from, for example, working Windows, and then, using flash-stick, get them to my Ubuntu and install it? Just how?
    – daGrevis
    Commented Jul 9, 2011 at 17:38
  • Is this the right one? Simply download? And then... how to install it on Ubuntu?
    – daGrevis
    Commented Jul 9, 2011 at 17:40
  • If you're using 11.04, isn't that Natty, not Lucid? Anyway, I'll repost in an answer below with full instructions.
    – bahamat
    Commented Jul 9, 2011 at 18:00

2 Answers 2


Looks like you're missing the linux-firmware packages. And since this is your network driver, that may make things complicated.

First, get these:

Copy the deb onto a USB drive (or burn to a CD) and get them available in Ubuntu. Exactly how is outside the scope of these instructions, and I'm assuming that either Ubuntu will know how to mount it for you or you know how to mount it yourself.

Once you've got it mounted copy the deb files to your home directory then open a Terminal and run this command:

dpkg -i linux-firmware*deb

Then reboot.

If Ubuntu natively supports your wireless chipset then this will solve the issue. If this doesn't solve the issue then you'll have to go for ndiswrapper.

  • I tried those two packages. It still doesn't work. Before I try ndiswrapper... maybe other Ubuntu version and not 64, but 32 bits may help?
    – daGrevis
    Commented Jul 10, 2011 at 9:14
  • I tried like this... I don't understand what does "then do your distribution-specific stuff to enable interfaces etc. etc." mean? How to do it on Natty?
    – daGrevis
    Commented Jul 10, 2011 at 9:56
  • I don't use Ubuntu, I use Debian, and never X. I would expect that you can use the network config in the menu bar to set up the rest.
    – bahamat
    Commented Jul 10, 2011 at 23:30

Edit: This answer doesn't answer the question, only helped figure out what the question was. I'll delete it when the comments are no longer helpful.

It looks like your hardware might have been detected automatically, so that's good.

I would skip that whole dialog box you found. That's the administration panel and chances are you don't need to make any changes at all in there. If you needed special paramaters such as setting your own IP addresses that would be the place to do it, but usually all you need to get connected are the basic user-controls.

You can find a menu in the top right of the screen (two arrows it looks like in your case). That menu should show list of available networks, wired, wireless, bluetooth, usb or otherwise. When you select a secured wireless network from the list it scanned, you should be prompted for the password.

  • Thanks for your answer. It won't be so easy... Any suggestions?
    – daGrevis
    Commented Jul 9, 2011 at 13:53
  • @daGrevis: The menu gives a pretty good hint! The wireless card needs proprietary firmware loaded in order to function. This is different than a driver which gets loaded on the computer side, firmware is code that gets sent to and runs resident to the device. This is sometimes a binary blob provided by the manufacture and distros like Debian can't distribute it on their media. Sometimes these will be in extra repositories tho. In my distro there are about a dozen special {chipset_name}-firmware packages that are not in the main distro but can be installed easily to support those chips.
    – Caleb
    Commented Jul 9, 2011 at 15:13
  • @daGrevis: I have taken the liberty of re-writing your question as it should have been written in the first place. Since you started off at all the wrong end of the stick, my answer is useless. Hopefully by asking the right question you can find somebody with the right answer. I don't know where to find that piece of the puzzle for Ubuntu.
    – Caleb
    Commented Jul 9, 2011 at 15:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .