1

I've plugged in a USB Hard Drive to my new Debian Jessie machine. I've got it to auto-mount by updating /etc/fstab:

UUID=21AE-9B96 /mnt/local/ext001 vfat defaults 0 2

...but it's owner is root and won't let me change anything. I've mounted it as /mnt/local/ext001 and have tried to:

sudo chown -R 1000:1000 ext001

...it grants me ownership over ext001, but nothing in it or below it, giving me:

Changing ownership of xyz, : Operation not permitted

I've attempted this using sudo and su. Where am I going wrong?

  • Try to adapt the permissions of the directory ext001 accordingly before mounting the VFAT volume. – Elias Probst Oct 20 '14 at 22:53
  • 1
    The fat32 filesystem doesn't keep track of file or directory ownership, but try adding uid=1000,gid=1000 to the mount options to make the files and directories appear to be that uid/gid. – Mark Plotnick Oct 21 '14 at 10:36
  • @MarkPlotnick You should post this as an answer. – Gilles Oct 21 '14 at 22:09
  • @EliasProbst No, that wouldn't help. This directory exists solely to be a directory entry which can be used as a mount point; its metadata is ignored. – Gilles Oct 21 '14 at 22:10
  • @Gilles OK. I'd like to wait for OP to confirm it solves the problem. – Mark Plotnick Oct 22 '14 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.