3

I am using KDE 4.13.3 on my Laptop and whenever I'm typing the cursor jumps to different places, because I accidentally touch the mousepad with my thumb. This is super annoying and other window managers have an option to disable the mousepad while typing.

How do I do this with KDE?

3 Answers 3

3

I guess you are using synaptics touchpad. If so install xf86-input-synaptics driver, which comes with syndaemon tool:

syndaemon - a program that monitors keyboard activity and disables the touchpad when the keyboard is being used

Once installed you can start it with -d (daemon) option. It is also possible to configure some settings like delay before re-enabling touchpad after last keyboard key was pressed.

2
  • This only works for old Ubuntu and Mint versions.
    – Stein
    Oct 21, 2014 at 17:04
  • Strange, on my just updated gentoo works very well.
    – jimmij
    Oct 22, 2014 at 15:36
0
sudo apt-get install kde-touchpad

and

sudo kcmshell4 kcm_touchpad

worked for me

0

Supposing you have a synaptic touchpad, as most do, install the synaptics driver if you have not already, usually called xf86-input-synaptics.

Installing the KDE touchpad config modules (usually kcm-touchpad or kde-touchpad) should provide you with the configuration GUI.

I am actually quite surprised this was not included by default by your distribution, if is ships with KDE by default.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .