5

I'm using reprepro to package some internal files for distribution via Puppet. When the puppet clients are hitting the repository I'm seeing errors like this:

[error] [client 10.20.xx.xx] File does not exist: /var/www/build/dists/POCL/private/i18n/Translation-en.lzma
[error] [client 10.20.xx.xx] File does not exist: /var/www/build/dists/POCL/private/binary-armel/Packages.lzma

There appear to be two files missing from my (mis)use of reprepro to generate packages. Something for translation support and another for a list of packages?

Is there a way to have reprepro generate these files? If not, how would I create them?

  • Do not add how to solve the issue in the body of your question, add it as answer. – Braiam Oct 20 '14 at 11:57
  • It's only a partial answer. – ethrbunny Oct 20 '14 at 11:57
  • It is an answer, therefore it shouldn't be in the question body. – Braiam Oct 20 '14 at 11:57
  • If I find a full answer (and is not submitted otherwise) I'll move this. – ethrbunny Oct 20 '14 at 11:58
4

This is normal. APT clients try to get translation packages for the repository. Is the normal behavior. You can either, ignore the message, disable the message reporting (sadly reprepo doesn't allow this) or configure your clients to not ask for the languages packages with Acquire::Languages "none"; line in your apt.conf file. There isn't a method for reprepo to generate the files so for now you have to live with it.

  • How about 'packages.lzma'? – ethrbunny Oct 20 '14 at 14:11
  • @ethrbunny is only a lzma compressed file which you don't generate. – Braiam Oct 20 '14 at 14:13
  • err.. ok.. adding the file to 'apt.conf.d' fixes the translation file issue.. but now I get errors for both 'packages.lzma' and 'packages.bz2'. The apache error logs are rapidly growing with errors from all the clients - which is why i would like to fix both issues. – ethrbunny Oct 20 '14 at 14:15
  • 1
    NOTE: full solution - to eliminate both messages create a file on the client: /etc/apt/apt.conf.d/99translations. In this file put two lines: Acquire::Languages "none"; and Acquire::CompressionTypes::Order:: { "lzma", "gz" }; – ethrbunny Oct 20 '14 at 15:24
  • 1
    @ethrbunny that only fix the issue at client side, do it at server side instead. – Braiam Oct 20 '14 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.