1

This question already has an answer here:

I have a problem

ANSI escapes in Pash prompt are displayed as garbage in Gnome terminal

$ mono Source/PashConsole/bin/Debug/Pash.exe
[%?%p1%{8}%<%t37%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;7%;m[%?%p1%{8}%<%t40%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;0%;mPash - Copyright (C) Pash Contributors.     License: GPL/BSD. See https://github.com/Pash-Project/Pash/
[%?%p1%{8}%<%t37%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;7%;m[%?%p1%{8}%<%t40%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;0%;m
[%?%p1%{8}%<%t37%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;7%;m[%?%p1%{8}%<%t40%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;0%;mPASH /home/gbuday/projects/Pash> [%?%p1%{8}%<%t37%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;7%;m[%?%p1%{8}%<%t40%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;0%;m 

that seemed to be a terminal one but it might be a Mono one. Might Mono not set termcap or terminfo properly and that causes that garbage to go on my terminal?

marked as duplicate by slm Oct 20 '14 at 11:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from stackoverflow.com Oct 20 '14 at 10:32

This question came from our site for professional and enthusiast programmers.

  • but this seems to be not a unix terminal question -- how can I move it to here where mono experts could say what they know? – Gergely Oct 9 '14 at 5:51
  • Then delete your original question at unix.SE first, or flag it for moderator attention to be moved here. – depquid Oct 9 '14 at 13:07
1

This is a bug in Mono:

https://bugzilla.xamarin.com/show_bug.cgi?format=multiple&id=18315

Using

TERM=xterm mono Source/PashConsole/bin/Debug/Pash.exe

cures the problem. The default

TERM=xterm-256color 

makes Mono to out that garbage.

Not the answer you're looking for? Browse other questions tagged or ask your own question.