2

I am trying to install packages, but I keep getting dependency errors.

I already installed the EPEL, IUS, REMI repos.

Example:

yum install gcc

and I get

Error: Package: devtoolset-2-gcc-4.8.2-15.1.el6.x86_64 (slc6-devtoolset) 
requires: glibc-devel >= 2.2.90-12   (and other dependencies)

and when I try to install glibc (or the other dependencies)

yum install glibc-devel*

I get

no package glibc-devel* available.  Nothing to do.


yum list installed |grep glibc* 

does not show any glibc-devel installed.

RHEL Version = 2.6.32-358.el6.x86_64

[root@localhost yum.repos.d]# yum repolist all
Loaded plugins: product-id, refresh-packagekit, replace, security, subscription-
              : manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
repo id                        repo name                          status
InstallMedia                   Red Hat Enterprise Linux 6.4       disabled
epel                           Extra Packages for Enterprise Linu enabled: 11,141
epel-debuginfo                 Extra Packages for Enterprise Linu disabled
epel-source                    Extra Packages for Enterprise Linu disabled
epel-testing                   Extra Packages for Enterprise Linu disabled
epel-testing-debuginfo         Extra Packages for Enterprise Linu disabled
epel-testing-source            Extra Packages for Enterprise Linu disabled
ius                            IUS Community Packages for Enterpr enabled:    232
ius-archive                    IUS Community Packages for Enterpr disabled
ius-archive-debuginfo          IUS Community Packages for Enterpr disabled
ius-archive-source             IUS Community Packages for Enterpr disabled
ius-debuginfo                  IUS Community Packages for Enterpr disabled
ius-dev                        IUS Community Packages for Enterpr enabled:     25
ius-dev-debuginfo              IUS Community Packages for Enterpr disabled
ius-dev-source                 IUS Community Packages for Enterpr disabled
ius-source                     IUS Community Packages for Enterpr disabled
ius-testing                    IUS Community Packages for Enterpr disabled
ius-testing-debuginfo          IUS Community Packages for Enterpr disabled
ius-testing-source             IUS Community Packages for Enterpr disabled
pgdg93                         PostgreSQL 9.3 6Server - x86_64    enabled:    256
pgdg93-source                  PostgreSQL 9.3 6Server - x86_64 -  disabled
remi                           Les RPM de remi pour Enterprise Li disabled
remi-debuginfo                 Les RPM de remi pour Enterprise Li disabled
remi-php55                     Les RPM de remi de PHP 5.5 pour En disabled
remi-php55-debuginfo           Les RPM de remi de PHP 5.5 pour En disabled
remi-php56                     Les RPM de remi de PHP 5.6 pour En disabled
remi-php56-debuginfo           Les RPM de remi de PHP 5.6 pour En disabled
remi-test                      Les RPM de remi en test pour Enter disabled
remi-test-debuginfo            Les RPM de remi en test pour Enter disabled
rhel-source                    Red Hat Enterprise Linux 6Server - disabled
rhel-source-beta               Red Hat Enterprise Linux 6Server B disabled
rpmforge                       RHEL 6Server - RPMforge.net - dag  enabled:  4,718
rpmforge-extras                RHEL 6Server - RPMforge.net - extr disabled
rpmforge-testing               RHEL 6Server - RPMforge.net - test disabled
slc6-devtoolset                Scientific Linux CERN 6 (SLC6) - D enabled:    458
slc6-devtoolset-debug          Scientific Linux CERN 6 (SLC6) - D disabled
slc6-devtoolset-source         Scientific Linux CERN 6 (SLC6) - D disabled
slc6-devtoolset-testing        Scientific Linux CERN 6 (SLC6) - D disabled
slc6-devtoolset-testing-debug  Scientific Linux CERN 6 (SLC6) - D disabled
slc6-devtoolset-testing-source Scientific Linux CERN 6 (SLC6) - D disabled
slc6-os                        Scientific Linux CERN 6 (SLC6) bas disabled
webtatic                       Webtatic Repository 6Server - x86_ enabled:    383
webtatic-debuginfo             Webtatic Repository 6Server - x86_ disabled
webtatic-source                Webtatic Repository 6Server - x86_ disabled
repolist: 17,213
  • Do an update "# yum update" – Ruban Savvy Oct 20 '14 at 9:26
  • Please add the output of yum repolist all to your question. – garethTheRed Oct 20 '14 at 11:18
  • You should be installing the gcc package from slc6-os.repo or slc6-updates.repo, then the dependancies will be provided from there too rather than using the devtoolset version. – geedoubleya Oct 20 '14 at 11:26
  • @geedoubleya I looked for instructions for downloading and installing the slc6-os repo but found none. On cern's own site (linux.web.cern.ch/linux/scientific6/docs/softwaremgmt.shtml) I found the text for the .repo file and created it in my /etc/yum.repos.d, but when I did a yum update - I got 1200+ updates and 422M! I cancelled that, and tried "yum install gcc" and it downloaded the 12 files, but failed during the GPGKey check. I compared the gpgkey check line to the one in an existing "slc6-devtoolset" on my system, and it matched. not sure why it's failing or what to try next – Jason Oct 22 '14 at 7:54
  • You need to indent each line by at least 4 spaces for it to format as code/output in the final output (and preview). – garethTheRed Oct 22 '14 at 8:10
2

You should be installing the gcc package from

slc6-os.repo or slc6-updates.repo

Then the dependancies will be provided from there too rather than using the devtoolset version.

Yum Repositories Entries

/etc/yum.repos.d/slc6-os.repo
/etc/yum.repos.d/slc6-updates.repo
/etc/yum.repos.d/slc6-extras.repo

Installation instructions

Location:

slc6-os.repo
slc6-updates.repo
slc6-extras.repo

Import the GPG key:

rpm --import http://linuxsoft.cern.ch/cern/slc6X/x86_64/RPM-GPG-KEY-cern
0

glibc-devel should be part of the base repo, you may have a some conflicts with your repos.

try disabling all the extra repos you added and try again.

You should also check yum Priorities plug-in which can prevent a 3rd party repository from replacing base packages, or prevent base/updates from replacing a 3rd party package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.