1

I'm using OpenSuSE 13.2 beta (which runs by the way very nicely). When starting up, my wireless adapter (Intel Centrino Ultimate-N 6300 AGN/Thinkpad T420) delays about one minute... But then it works absolutely fine!

dmesg:

[   84.292640] iwlwifi 0000:03:00.0: Direct firmware load failed with error -2
[   84.292643] iwlwifi 0000:03:00.0: Falling back to user helper
[...]
[  144.384396] iwlwifi 0000:03:00.0: Direct firmware load failed with error -2
[  144.384407] iwlwifi 0000:03:00.0: Falling back to user helper
[  204.559711] iwlwifi 0000:03:00.0: loaded firmware version 9.176.4.1 build 15835 op_mode iwldvm
[  204.581718] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
[  204.581728] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[  204.581734] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[  204.581740] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[  204.581909] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  204.601963] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[  204.628809] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  204.629075] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  204.844393] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  204.844626] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

Face the time difference between the first attempt (84), that fails without any further message, the second (144) and the success (204)! What the hell is linux doing? Any idea how to solve this problem? I already downloaded the firmware file from wireless.kernel.org and replaced the system-delivered one, but no enhancement...

[This post is originated on Stackowerflow, but someone reminded me, that it's not located correctly over there: https://stackoverflow.com/questions/26433700/iwlwifi-timeout-delays-firmware-to-be-loaded]

2
  • NOTE: I flagged to have the cross-post deleted on SO, so leave this one alone!
    – slm
    Oct 19, 2014 at 17:58
  • I get the same behavior with kernel 3.14.26 on arch/T410, but with kernel 3.17.6 there's no such timeout
    – yhager
    Dec 14, 2014 at 8:21

1 Answer 1

1

I believe this can be fixed by setting CONFIG_FW_LOADER_USER_HELPER=n and recompiling the kernel. Later kernels have this set to n by default.

If this is not an option for you, try adding to /etc/udev/rules.d/50-firmware:

SUBSYSTEM=="firmware", ACTION=="add", ATTR{loading}="-1"

(create the file if it does not exist) and reboot. It helped for my case.

More details here: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1398458

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .