My target is about playing Team Fortress 2 on Kali Linux (a Debian Wheezy stable distribution with customized Debian Sid kernel) since a long time now, but couldn't because of the following graphical glitches:

  • Bad dark textures
  • Very low FPS
  • Low brightness
  • Green texture on training video
  • Ugly grain effect on textures

The solution after a lot of research was to compile a newer version of Mesa over 8.0.5. I used the "official" guide made by the Debian's Mesa maintainer:


But I'm now stuck at the ./configure process, because it says that libdrm_nouveau should be at least 2.4.33 while dpkg reports me that the version is 2.4.40. So the question is:

Did anyone managed to overcome this version problem, then complete the full building or installation process ?

I have the same problem than: stackoverflow.com/questions/20827233/installing-mesa-10-on-debian, but since I use Mesa 9.0.3, I meet that problem instead of the libdrm-intel's one.

Here's my computer:

  • Core I5 with HD 3000 and GT 540M
  • Kali Linux 1.0.9 updated
  • Kernel 3.14 i686-pae with nvidia 331.67 kernel modules
  • bumblebee-nvidia installed through wheezy-backports repository

My steps:


And the make bug report:

checking for NOUVEAU... no
configure: error: Package requirements (libdrm_nouveau >= 2.4.33) were not met:

Requested 'libdrm_nouveau >= 2.4.33' but version of libdrm_nouveau is 0.6

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NOUVEAU_CFLAGS
and NOUVEAU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Here's the result of "dpkg -l | grep libdrm:

ii  libdrm-dev                              2.4.40-1~deb7u2                    i386         Userspace interface to kernel DRM services -- development files
ii  libdrm-intel1:i386                      2.4.40-1~deb7u2                    i386         Userspace interface to intel-specific kernel DRM services -- runtime
ii  libdrm-nouveau1a:i386                   2.4.40-1~deb7u2                    i386         Userspace interface to nouveau-specific kernel DRM services -- runtime
ii  libdrm-radeon1:i386                     2.4.40-1~deb7u2                    i386         Userspace interface to radeon-specific kernel DRM services -- runtime
ii  libdrm2:i386                            2.4.40-1~deb7u2                    i386         Userspace interface to kernel DRM services -- runtime

Even if I use Kali Linux, every packages I'm working are exactly the same in Debian 7.6 (Versions checked with a VM).

I also managed to compile Mesa 10.0.5 and finished the tutorial. Instead of using the paths used in this latter for the exports,I used mine's that point correctly to the libraries. But I'm still hitting on problems.

My steps were:

# autoreconf -vfi
# ./configure --prefix=/usr --enable-driglx-direct --enable-gles1 --enable-gles2 --enable-glx-tls --with-dri-driverdir=/usr/lib/dri --with-egl-platforms='drm x11' --with-dri-drivers=i965
# make
# checkinstall

Furtherore, I didn't installed mesa-common-dev since it conflicts with the newly installed Mesa. I also didn't made 'mv lib/gallium/* lib/' as suggested since my GPU is an Intel one. While doing the checkings, I faced this in comparison, so it looks like it didn't worked:

# export LIBGL_DRIVERS_PATH=/usr/lib/dri
libGL: OpenDriver: trying /usr/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib/dri/i965_dri.so
libGL error: unable to load driver: i965_dri.so
libGL: OpenDriver: trying /usr/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/dri/swrast_dri.so
# export LD_LIBRARY_PATH=/usr/lib
libglapi.so.0 => /home/user/Data/Mesa-10.0.5/src/mapi/shared-glapi/.libs/libglapi.so.0 (0xb772c000)
# export EGL_DRIVERS_PATH=/usr/lib
# EGL_LOG_LEVEL=debug es2_info 2>&1 >/dev/null | grep '\.so'

The last test returned nothing, making it even weird. Even if I perfectly followed the guide, it's still not working, is there something implicitly said that I didn't noticed ?

closed as off-topic by Braiam, slm Oct 18 '14 at 16:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This libdrm_nouveau thing belongs to the libdrm source package. Looking at the build dependencies, it should be possible to backport it. – Faheem Mitha Oct 18 '14 at 1:15
  • How do you look a the build dependencies ? I'm not accustomed to backporting. If you mean with dpkg, it's says me that it's version 2.4.40-1. – X.LINK Oct 18 '14 at 1:22
  • apt-cache showsrc libdrm-nouveau2. The Build-Depends line. – Faheem Mitha Oct 18 '14 at 1:25
  • It says unable to locate package libdrm-nouveau2, with Synaptic I found libdrm-nouveau1a – X.LINK Oct 18 '14 at 1:27
  • The libdrm-nouveau2 is from Debian jessie. My answer may not be directly applicable, because I see you are not actually using Debian. Can you post the output of dpkg -l | grep libdrm into your question? – Faheem Mitha Oct 18 '14 at 1:30

Browse other questions tagged or ask your own question.