I have a server that I have inherited that has an older version of Redhat installed due to software requirements and now there is a need to use UUENCODE to allow email attachments. The uuencode and uudecode files are not in /usr/bin. I tried copying them from another server but I receive an error:

/lib64/tls/libc.so.6: version `GLIBC_2.4' not found when we try to run it.

It appears that I may need to install the sharutils.rpm but I am not sure which one to download? Can anyone either point me to the correct rpm to download or an alternative method for processing uuencode?

Server Details:

$ cat /proc/version
Linux version 2.6.9-42.ELsmp (bhcompile@ls20-bc1-13.build.redhat.com) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-2)) #1 SMP Wed Jul 12 23:32:02 EDT 2006

$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 4)

$ uname -a
Linux <servername> 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

Have you tried using yum to access the the RHEL repositories and install the version of sharutils that matches your release?

$ yum update
$ yum install sharutils

CentOS packages are generally one-to-one equivalents to RHEL packages with branding removed. You could try manually downloading a package from them. It looks like you could get that package here:

$ wget http://mirror.rackspace.com/CentOS/4/apt/i386/RPMS.os/sharutils-4.2.1-22.2.i386.rpm
  • Thanks. That package seems to solve the problem (pending the end users testing). It won't let me upvote the answer for some reason so I want to say thanks! – user739866 Jul 8 '11 at 13:45

How to get uuencode on Fedora 17 Linux

Find out what provides for uuencode using yum:

yum provides uuencode

Read what yum tells you:

sharutils-4.11.1-3.fc17.x86_64 : The GNU shar utilities for packaging 
                                 and unpackaging shell archives
Repo        : @updates
Matched from:
Filename    : /usr/bin/uuencode

Oh Look! 'sharutils' provides uuencode

Install that:

yum install sharutils

You get this output:

[root@defiant el]# yum install sharutils 
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ftp.usf.edu
 * rpmfusion-free: mirror.hiwaay.net
 * rpmfusion-free-updates: mirror.hiwaay.net
 * rpmfusion-nonfree: mirror.hiwaay.net
 * rpmfusion-nonfree-updates: mirror.hiwaay.net
 * updates: mirror.hiwaay.net
Resolving Dependencies
--> Running transaction check
---> Package sharutils.x86_64 0:4.11.1-3.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

 Package                                                Arch                                                Version                                                      Repository                                            Size
 sharutils                                              x86_64                                              4.11.1-3.fc17                                                updates                                              176 k

Transaction Summary
Install  1 Package

Total download size: 176 k
Installed size: 612 k
Is this ok [y/N]: y
Downloading Packages:
sharutils-4.11.1-3.fc17.x86_64.rpm                                                                                                                                                                           | 176 kB     00:00     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : sharutils-4.11.1-3.fc17.x86_64                                                                                                                                                                                   1/1 
  Verifying  : sharutils-4.11.1-3.fc17.x86_64                                                                                                                                                                                   1/1 

  sharutils.x86_64 0:4.11.1-3.fc17                                                                                                                                                                                                  


Then test to see if it works

[root@defiant el]# which uuencode
[root@defiant el]# uuencode --version
uuencode (GNU sharutils) 4.11.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.