1

I've been trying to get the NVIDIA drivers to work on my Lenovo Y50 (GTX 860m) for a while. After installing them and rebooting, I get a black screen with some unhelpful text, which I usually remedied by logging into a shell and purging the drivers.

However, in my latest attempt, the problem persisted after purging the drivers. After trying many different things, I eventually fixed the error by re-installing lightdm and changing to the lightdm-gtk-greeter.

I wasn't sure which method worked, so I switched back to the pantheon-greeter and restarted lightdm, which again gave me a black screen.

In addition, the shell windows appear to be at a lower resolution than usual, although the desktop terminal reports to be running at 1080p, so it's not a huge issue.

The final (and most severe) problem is that the desktop is suddenly ugly and unusable. There are no close/minimize/maximize buttons and the appearance of nearly everything changed. I checked my settings in tweaks and none of them have been altered. I tried re-installing pantheon to no avail. I may have broken something in my attempts to fix the GUI but can't think of what it might be.

I'm mostly concerned with the issue of the desktop, but insight into the issue of the greeter or why I can't get the drivers to work in the first place are welcome. I suspect they're closely related.

My kernel version is 3.16.3.

Here's a screenshot of the desktop: enter image description here

  • same problem here, tried to reinstall elementary-desktop, didnt work – Enoque Duarte Nov 24 '14 at 5:32
  • Same, but when I re-installed I did so in such a way that some data was preserved. I nuked the partition and re-installed, which fixed it. Haven't messed with drivers yet. – HashFail Nov 24 '14 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.