2

I'm trying to get Debian Jessie to boot to CLI, to allow me to start KDE manually.

I've tried:

sudo update-rc.d kdm disable

...but this results in:

insserv: warning: current start runlevel(s) (empty) of script `kdm' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `kdm' overrides LSB defaults (0 1 6).

Secondly, how do I start KDE manually.


I also reversed with the same first command (but enable) and then tried the following:

update-rc.d -f kdm remove
update-rc.d kdm stop 20 2 3 4 5 .

....which resulted in:

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start runlevel arguments (none) do not match kdm Default-Start values (2 3 4 5)
update-rc.d: warning: stop runlevel arguments (2 3 4 5) do not match kdm Default-Stop values (0 1 6)

But the system still boots into KDE login prompt.

1
  • Does Debian still have /etc/inittab?
    – SailorCire
    Oct 15, 2014 at 11:11

2 Answers 2

3

First, the "insserv: warning" ... is just that, warnings. The command has still succeeded and would have disabled kdm from starting automatically.

However, in order to disable the display manager, you could instead edit /etc/X11/default-display-manager and make sure the file exists but is empty.

Reboot and you should get to the console.

If you need to re-enable a display manager, you should use:

sudo update-alternatives --config x-window-manager

Your second question, "how do i start kde manually?":

the command is startkde

you may also reconfigure X11 to start kde by default, and then "startx" would bring up kde for you.

Here is a related question: How to boot Debian into text mode without using GUI?

2
  • Thanks, I've had bits of similar assistance on G+,. but the whole story. This seems far more coherent, will check out later and Tick when (and if) it works, which I'm sure it will. Oct 16, 2014 at 7:30
  • I get [$DISPLAY is not set or cannot connect to the X server.] Oct 16, 2014 at 21:55
0

After asking this question on a number of forums, it seems that there may be a number of ways to A: Force booting to console and B: start KDE once at the console. I've however found, that only the following works, for me.

update-rc.d kdm disable
reboot

My system now boots to CLI. I login and

service kdm start

The KDE login screen (KDM) starts, allowing me to login to KDE.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .