0

If I run

indicator-cpufreq

in the console it will start up just like it is supposed to and appear in the panel. However, if I place the same command in the startup programs it doesn't appear on login.

I'm using Mint Linux and the Cinnamon desktop. How can I run this program on login?

  • Try making it wait a few seconds before starting up. – slm Oct 14 '14 at 23:51
  • Makes a perfect sense to bump 2014 questions. Not. – ajeh May 23 '18 at 18:16
0

This worked for me in Mint 17.1

Create a desktop launcher & name it appropriately. Edit the launcher using a text editor as follows:

[Desktop Entry]
Comment=CPUFreq Indicator Icon
Terminal=false
Name=Indicator-CpuFreq
Exec=indicator-cpufreq
Hidden=false
NoDisplay=false
Type=Application
Icon=gnome-panel-launcher
X-GNOME-Autostart-enabled=true

Copy the launcher to ~/.config/autostart

Test by logging out and back in

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.