3

I am running a Kali Linux in a virtualbox. I want to test the security of my wifi router with airmon-ng etc.

When I run airmon-ng start eth0 Kali should create an additional interface. However it does not create that interface. Kali's eth0 is brigded to the host's wlan0 interface.

  • Why airmon-ng does not create the mon0 interface?

Thanks to @Jan here more information about the Kali and the host system. The host system is a Ubuntu 14.04.

The host system

> iwconfig

 wlan0     IEEE 802.11abgn  ESSID:"some ssid"  
           Mode:Managed  Frequency:2.412 GHz  Access Point: <some MAC>
           Bit Rate=78 Mb/s   Tx-Power=15 dBm   
           Retry  long limit:7   RTS thr:off   Fragment thr:off
           Power Management:on
           Link Quality=70/70  Signal level=-34 dBm  
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:10   Missed beacon:0

 > sudo airmon-ng start wlan0

 Found 5 processes that could cause trouble.
 If airodump-ng, aireplay-ng or airtun-ng stops working after
 a short period of time, you may want to kill (some of) them!

 PID    Name
 1098   avahi-daemon
 1102   avahi-daemon
 1118   NetworkManager
 1145   wpa_supplicant
 6002   dhclient
 Process with PID 6002 (dhclient) is running on interface wlan0

 Interface  Chipset     Driver

 wlan0      Unknown     iwlwifi - [phy0]
            (monitor mode enabled on mon0)

On Kali@virtualbox

> iwconfig

eth0 no wireless extensions

lo no wireless extensions


> airmon-ng start eth0

Interface Chipset Driver
3

I don't use anymore airmon-ng to enable monitor mode because it stop the network-manager service.

I prefer :

ifconfig wlan0 down;
iwconfig wlan0 mode monitor;
if config wlan0 up;

as it is say up try iwconfig to check wlan0 mode

1

You don't mention your chipset, driver, kernel and airmon-ng version, which would have made it easier to help you.

Not all drivers create mon0 for monitor mode, some enable it on the original interface (wlan0 in your case). Run airmon-ng check to check the status. To confirm that your card is in monitor mode, run the command iwconfig. You can then confirm the mode is “monitor” and the interface name.

You could also run airmon-ng check kill, which will cause all processes that use the interface to exit.

For the mac80211 drivers, the monitor mode interface is typically “mon0”. For ieee80211 madwifi-ng drivers, it is typically “ath0”. For other drivers, the interface name may vary.

Source

To learn more about the difference of the drivers, read here

  • I added more information about the host and the virtualbox system. I can create a mon0 on the host system - but not on the virtualbox. – Philipp Oct 14 '14 at 20:53
  • @Philipp err... if I'm not mistaking, you can't use monitor mode in a virtualized environment – Braiam Oct 20 '14 at 8:46
1

The official documentation for Kali from Offensive Security states that you'll have to get a USB adapter with the proper chipset to use WiFi in a virtual environment.

0

You have to type:

sudo airmon-ng start mon0

noticing that the interface is mon0 that has been enabled monitor mode.

" wlan0      Unknown     iwlwifi - [phy0]              
(monitor mode enabled on mon0)"
0

As for me, I will execute airmon-ng check kill before changing to monitor mode.

Just like below:

iwconfig wlan0
ifconfig wlan0 down
airmon-ng check kill
iwconfig wlan0 mode monitor
ifconfig wlan0 up
iwconfig wlan0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.