4

I am working on a Colibri module having Angstrom linux installed in it! The processor is ARM v7. I am having trouble updating the softwares installed in the system.

Whenever I tried the command opkg update, I'd get a bunch of errors. Probably, it seems that the support from Angstrom project has been withdrawn as it gives 404 content not found error.

The error message is:

$ opkg update
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/base/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/debug/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/gstreamer/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/all/Packages.gz.
Inflating http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/all/Packages.gz.
Updated list of available packages in /var/lib/opkg/lists/no-arch.
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/perl/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/python/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
* opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/base/Packages.gz, wget returned 1.
* opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/debug/Packages.gz, wget returned 1.
* opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/gstreamer/Packages.gz, wget returned 1.
* opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/perl/Packages.gz, wget returned 1.
* opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/armv7ahf-vfp-neon/python/Packages.gz, wget returned 1.
404 Not Found
feeds.angstrom-distribution.org

Also, I tried installing package gcc by using the command opkg install gcc, but the same result. Again, surprisingly, the error message is unbelievable...

$ opkg install gcc
Unknown package 'gcc'.
Collected errors:
* opkg_install_cmd: Cannot install package gcc.

I have no idea as to how to resolve this error as it is completely surprising. Also, it is of immense importance as I have to complete it within 2 days of installing gcc and running C programs...

3
  • 1
    I think you're having some other issue. I was able to browse to the angstrom-distribution.org website. There was no Packages.gz file in that directory but other directories around it had files. – slm Oct 14 '14 at 13:11
  • @slm-that's what the problem is,there is no such file on their website,I couldn't find any directory! Would you mind providing links to those directories which contains files. Thanks for responding. – Am_I_Helpful Oct 15 '14 at 0:46
  • The URLs from above: feeds.angstrom-distribution.org/feeds/v2014.06/ipk/eglibc/…. I went up a level there and then under machines are subdirectories w/ package files etc. – slm Oct 15 '14 at 0:48
3

Sorry I just saw your question now, and I had to deal with the same issue on Apalis T30. Toradex is quite helpful if you ask them questions, but I found the solution myself in their release notes.

Newer images of Toradex builds for Apalis and Colibri have an issue with the Angstrom package feeds. (V2.3 Beta1+ is my understanding). You will need to manually change some files in the /etc/opkg/*.conf to make it work. Search for armv7ahf-vfp-neon and replace them with armv7at2hf-vfp-neon. From Toradex's release notes file Colibri_T30_LinuxReleaseNotesV2.x.txt:

  • The Angstrom-Distribution since switched to using ARM Thumb2 instruction set. To use their binary feeds e.g. using the opkg package manager please change in /etc/opkg/base-feed.conf et. al. armv7ahf-vfp-neon to armv7at2hf-vfp-neon. We consider switching in our next release.

On Apalis T30 I had to change 5-6 .conf files to make it work.

2
  • I did the same and I also got it successfully resolved a month ago. Thanks,but,I am unable to install gcc on that Colibri T-30 board,neither using native compilation,nor using Cross Compilation... – Am_I_Helpful Nov 15 '14 at 6:16
  • 1
    I installed packagegroup-sdk-target on my system (Apalis T30) with this V2.3 Beta2 and gcc works there. developer.toradex.com/software-resources/arm-family/linux/… As I recall I had to run the opkg install twice to make it install completely, not sure why. – kegsys Nov 19 '14 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.