3

I have windows 7 with 32 bit system, and previously I used CentOS-6.5-i386-minimal to run centos on my virtual box, but now I would like to run CentOS 7 and it seems (if I am not mistaken) that there are No links to download an i386 image, as there are only x86_64 which I am assuming is for the 64 bit systems.

edit:

despite the answers I got here, I was able to install CentOS 7 and start working with no problem.

enter image description here

4

If you're running 32-bit Windows 7 on a 64-bit processor, then VirtualBox can run a 64-bit guest with a few caveats:

3.1.2. 64-bit guests

VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems, provided that the following conditions are met:

  1. You need a 64-bit processor with hardware virtualization support (see Section 10.3, “Hardware vs. software virtualization”).

  2. You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

  3. If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

To check whether your processor supports virtualization from Windows hosts, use the Microsoft Hardware-Assisted Virtualization Tool.

To check whether your processor supports virtualization from Linux hosts, run:

egrep '(vmx|svm)' /proc/cpuinfo

The above checks for either vmx or svm in /etc/cpuinfo. If it finds either, it prints out all of the flags. However, if it doesn't find them, it will not print anything. The latter means you do not have hardware virtualization.

  • Hmm, I guess this answer my question. From the description I can understand, that if atleast I have visualization support (which I have, since I have been using CentOS 6.5 on a virtualbox) then I should be able to run 64bit. right? – robue-a7119895 Oct 14 '14 at 11:45
  • Only if you were running the 64-bit version of CentOS6.5. Check your processor - I've added to my answer. – garethTheRed Oct 14 '14 at 11:58
  • thanks, but are you sure that command is correct? I run it, and I get nothing. No response at all. – robue-a7119895 Oct 14 '14 at 13:27
  • Unfortunately, that means you do not have hardware virtualization - I've edited my answer. – garethTheRed Oct 14 '14 at 14:13
  • Well, actually I managed to install CentOS 7. Which I am working on right now. So, there must be something wrong with your answer, or maybe some bug or something. – robue-a7119895 Dec 22 '14 at 4:17
4

From the CentOS wiki:

CentOS aims to be 100% binary compatible with its upstream source, Red Hat Enterprise Linux (RHEL)

From the Red Hat website:

Red Hat Enterprise Linux 7 will only provide 64-bit ISO's, thus allowing only a 64-bit operating environment. However, 32-bit is supported in the following ways:

  • RHEL 7 will continue to provide selected libraries in both 32-bit and 64-bit, allowing 32-bit applications to run in the 64-bit RHEL 7 OS environment. This functionality also exists for RHEL 5 & 6 as documented in the knowledge article: How to install 32-bit packages on a 64-bit system
  • RHEL 7 will continue to support the multilib toolchain, allowing applications to be compiled for both 32-bit and 64-bit.
  • RHEL 7 can host, using KVM virtualization technology, both 32-bit and 64-bit virtual guest instances of RHEL 5 and RHEL 6

While RHEL 7 will not natively support 32-bit hardware, certified hardware can be searched for in the certified hardware database.

  • I am struggling to find a concrete and tangible answer in the second paragraph, aside from the fact that their "solution" takes me the a login page. I guess, only fedora can provide CentOS 7 for 32 bit systems. – robue-a7119895 Oct 14 '14 at 11:24
  • Their solution is for 32-bit applications to run on the 64-bit operating environment. I do not know any details about an apparent community supported 32 bit edition being created. – geedoubleya Oct 14 '14 at 11:38
  • 1
    Fedora has nothing to do with CentOS, they're totally different distros. – slm Oct 14 '14 at 13:01
  • @slm I know that. I was just assuming that maybe CentOS does not have that option. (running a 64bit image on a 32bit distro) – robue-a7119895 Oct 14 '14 at 13:45
0

It seems there is another distribution based on RHEL called Springdale and it has both 64-bit and 32-bit versions: http://springdale.math.ias.edu/

Take it with a grain of salt though, I haven't tried it and I don't know what are the differences between this and CentOS (if there are any).

  • Actually as stated already later in the comment, it was possible for me to install CentOs7 on 32bit. – robue-a7119895 Mar 3 '15 at 19:42
  • sadly, Springdale still ships systemd, so it's out as a successor in my shop; but shipping a 32-bit version is nice. I think there were some 32-bit respins of centos7, too. – user2066657 May 28 '18 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.