1

I have just installed Linux Mint 17 on my desktop computer with a Intel HD 4600 graphics card. Unfortunately it only supports a low resolution of 1920 x 1200 which looks horrible in contrast to the monitor's native 2560 x 1440.

I have spend 3 hours googling around trying different suggestions without luck. This post looked promising but the suggestions didn't help.

Mint 16 boots up in the correct resolution straight from a LiveUSB so something has changed (upstream probably) between the two versions.

There is a Intel graphics installer but when I run it, it says "Distribution not supported". I can fake an Ubuntu distro by editing lsb-release and then it installs something but still I can't choose the correct resolution in the Displays utility.

According to the Intel download center for HD 4600 there is a driver for Linux. But where on earth is the download link on that page? I really can't find it!

What options are there?

EDIT: I forgot to mention that I have tried forcing a new resolution with xrandr but I get a xrandr: Configure crtc 0 failed when I try to apply the new modes.

  • I'd be interested in any feedback you get. I've installed Debian Wheezy on a desktop that has a Gigabyte GA-B85N motherboard with Intel HD4600 Graphics onboard and cannot get it to resume from Standby/Hibernation properly. The HDMI signal to the monitor is non existent so the monitor stays off. – aSystemOverload Oct 13 '14 at 12:10
1

I had the same problem, and I found a page in portuguese that explains a workaround.

Before running the Intel Installer change your /etc/lsb-release and input those contents:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"

Install the drivers and revert the changes on the file.

After a reboot:

$ sudo su
# lshw -c video
  *-display               
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:60 memory:b0000000-b03fffff memory:a0000000-afffffff ioport:3000(size=64)

The driver is shown as "i915" that is the module installed. \o/

  • Thanks, but I already tried that. – marlar Nov 16 '14 at 17:00
0

I wrote in my questions that I tried to force the mode with xrandr but got an error. I tried to obtain the mode lines with cvt and gtf which appeared to be the way to get these. But none of the obtained mode lines worked, so I gave up on xrandr and tried other solutions.

Actually, I even bought a new graphics card, and while unpacking it, I decided to give the existing card a last chance.

I looked in Xorg.log (like I did several times before) but this time, after trying so many combinations of mode lines, I noticed that the listed mode lines were a bit different than those obtained from cvt and gtf. Interesting!

So I tried these mode lines with xrandr and bingo! I suddenly had a working mode line that forced the resolution into 2560 x 1440.

The last step was to simply add the mode to xorg.conf which looks like this:

Section "Monitor"
    Identifier "HDMI1"
    Modeline "2560x1440x0.0"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
EndSection

Section "Screen"
    Identifier "HDMI1"
    Device "Card0"
    Monitor "Monitor0"
    SubSection "Display"
        Modes "2560x1440x0.0"
        Depth 24
    EndSubSection
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.