0

When I try to install Jekyll on Elementary OS Luna with the command sudo gem install jekyll --no-rdoc --no-ri I get the following error.

 -- rbconfig (LoadError)
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:29
from /usr/bin/gem:8:in `require'
from /usr/bin/gem:8

Can anybody help me make sense of the error and maybe suggest a fix?

  • What version of gem are you using? From where? I tried reproducing the problem with gem install --user-install jekyll --no-rdoc --no-ri and was without a hitch on Debian Testing, gem version 2.2.2. – Braiam Oct 15 '14 at 11:51
  • I think your issue is that you're using a fairly old version of Ruby, v1.8. I'd upgrade that and try again. Myself and Braiam have both tried this using Ruby (2.1.1 in my case) and it is working fine. – slm Oct 15 '14 at 12:20
0

I would suggest upgrading to a newer version of Ruby. I tried building the Jekyll gem on 1.9 and it failed here:

ERROR:  Error installing jekyll:
    listen requires Ruby version >= 1.9.3.

However when I installed it on this version:

$ ruby --version
ruby 2.1.1p7 (2014-01-15 revision 44603) [x86_64-linux]

It installed just fine.

0

The problem was that I didn't run /bin/bash --login before I installed Jekyll

  • Thanks for posting your solution but could you please expand on it a little? Show the exact commands needed to fix this? – terdon Oct 15 '14 at 13:44
  • are you using rvm? – slm Oct 15 '14 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.