1

I am not able to start the operating system. Whenever I try to start the operating system it shows the following error:

file /boot/grub/i386-pc/normal.mod not found
Entering rescue mode... 
grub rescue> 

I have ubuntu on my pc along with windows 8.1. How can I resolve this problem?

I tried installing Ubuntu 14.04 onto my computer which was preloaded with windows 8.1. My goal was to make this a dual boot.

I primarily followed the instructions on this link: http://www.everydaylinuxuser.com/2014/05/install-ubuntu-1404-alongside-windows.html.

I accidentally skipped step 5, which was turning off secure boot, and is most likely what led to my current error. Ubuntu installed on my computer but I was unable to run it past the live session which prompted me to try out Ubuntu and/or install it again. But now I can't even get there.

In frustration, I removed my flash drive and that is when I arrived at this screen, which I can't seem to get out of. (can't boot into neither Ubuntu nor Windows)

If helpful, entering the command 'ls' on the grub rescue mode prompt outputs: "(hd0) (hd0,gpt 12) (hd0,gpt 11) (hd0,gpt 10) (hd0,gpt 9) (hd0,gpt 8) .... (hd0,gpt 2) (hd0,gpt 1)"

'set' outputs: "cmdpath=(hd0) prefix=(hd0,gpt10)/boot/grub root=hd0,gpt10"

These are pretty much the only two commands that work (that I know of). I've tried things like, 'quit', 'exit', 'lsmod' (I saw this might be useful on a different post), but none have worked.

0

If grub boots then so should your usb stick.

Is there a boot menu in your bios(try pressing F12, F1, ESC, DEL or some other key when you power on your pc); if there is, insert your usb and try finding it in the menu.

If you cannot find it try setting bios to legacy mode.

If that doesn't work try one of these commands in grub rescue. For Ubuntu 14.04.1:

linux (hd0,X)/boot/vmlinuz-3.13.0-32-generic root=/dev/sdaX
initrd (hd0,X)/boot/initrd.img-3.13.0-32-generic

For Ubuntu 14.04:

linux (hd0,X)/boot/vmlinuz-3.13.0-24-generic root=/dev/sdaX
initrd (hd0,X)/boot/initrd.img-3.13.0-24-generic

replace X whit partition number (just try all of the ones listed in ls until it works) then run command

boot
  • Hi, thank you for your response. At the moment, my computer does not boot onto neither Ubuntu nor Windows. The only screen that comes up is the grub rescue screen. I tried the commands you stated above, but for both 'linux (hd0,X)...' and 'initrd (hd0,X)...' I get the message saying 'Uknown command "linux" [same for initrd]' 'root=/dev/sdax' does work but I am assuming that is because it is setting it as a variable. Is there something else I can do? – gbrlrz017 Oct 12 '14 at 18:14
  • @GabrielRuiz can you not enter bios or boot menu on your computer? if you can then try disabling uefi completely and go to legacy mode then try inserting usb/cd whit ubuntu on it – nnnn20430 Oct 12 '14 at 19:46
  • yes, I just figured out how to get to the Boot Option Menu. I have the following options: "SATA HDD: ...." which reboots and sends me back to grub rescue; "SATA ODD: ..." which does the same; "USB HDD: ..." which sends me to a different menu that asks if I want to install linux, try linux (live session), and a few others things; "EFI USB Device" which does the same as the previous; "Windows Boot Manager" which reboots into Windows, and "Network Boot: Realtek..." which also boots into Windows. How should I go about disabling uefi and going into legacy mode? – gbrlrz017 Oct 12 '14 at 20:02
  • whats the name of the BIOS? try looking for a tab called boot and see if there's option called boot mode change it to legacy. then try reinstalling Linux from "USB HDD: ...". – nnnn20430 Oct 12 '14 at 22:05
  • So I just now was able to successfully make my laptop a dual boot. The way I got rid of the grub rescue prompt was actually by disabling Legacy Mode and switching to UEFI. Then I was able to turn Secure Boot Off. After this, when I rebooted I had the option to choose Ubuntu or Windows. Thanks for your help! – gbrlrz017 Oct 12 '14 at 23:26
0

So I just now was able to successfully make my laptop a dual boot.

The way I got rid of the grub rescue prompt was actually by changing my boot mode from Legacy Mode to UEFI. I did this by booting into the bios menu when I turned on my computer by pressing f2 (for me). I then scrolled over to Boot and switched this under the Boot Mode option.

This got rid of the grub rescue screen upon powering up my machine. When I turned it on, it took me into Windows. However, I was not given the option to choose Ubuntu or Windows. Rather, I went straight into Windows. My next step was to disable secure boot, since secure boot is a form of protection for your computer and does not allow you the option to choose operating systems (see http://technet.microsoft.com/en-us/library/dn481258.aspx for more info on this).

NOTE: the disable secure boot does not appear until after you switch to UEFI. I was now able to turn Secure Boot Off. The way to do this was also on the BIOS menu. I simply scrolled left to the Security tab (NOTICE: you should see an option for Secure Boot on the Bottom. You need not disable this, since my next instruction will disable it). I scrolled all the way down to Reset to Setup Mode and pressed enter. This Clears PK, disables Secure Boot (see for yourself on that screen) and enters Setup Mode. On a side note: I tried simply disabling Secure boot many times, saving it each time but this did not change anything when I restarted my computer (still booted to Windows automatically).

After this, when I rebooted I had the option to choose Ubuntu or Windows (since Ubuntu was already installed).

I did this on a Lenovo P400, so these steps may not be exact for all computers. Use your intuition where applicable. My understanding is that this whole UEFI thing is unique to new operating systems, including but not limited to Windows (8 and 8.1).

Hope this works for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.