0

Since today Netflix supports (or better doesn't block) Linux/Chrome for Linux. But it requires a newer version of libnss3 than the one that is in the Wheezy repository.

I solved this problem earlier by adding the Jessie repository and installing the library from there (which seems to be the most common solution you find on the internet). This lead to lots of dependencies getting updated/installed which further lead to dependency conflicts when installing other packages. Eventually it lead to a very unstable system with at some point booted into a kernel panic.

Not that big of a problem here because I just reinstalled Debian Wheezy. (wasn't that long running anyways) But I am facing the same problem now. Is there any possibility installing libnss3/watching Netflix without the need of adding the Jessie Repository? Or is there a better way of doing this which will not lead to a broken system?

  • 1
    I get tired of saying this, but just backport it? Sigh. See unix.stackexchange.com/q/112157/4671 I haven't checked out libnss3, but for basic libraries not tied to the toolchain, it is usually not hard. If you want further information, say so. – Faheem Mitha Oct 10 '14 at 20:13
  • I tried this and debuild exited with "debuild: fatal error at line 1357:". Also I tried just editing the .deb file from jessie. It installed but didn't work. Isn't there a statically linked version of libnss3? – Martin Oct 11 '14 at 14:22
  • You tried what, exactly? Be specific. Didn't work? Again, be specific. Please give details of what you tried to do and maybe I or someone else can advise you how to proceed. Working with software does require some measure of patience. Oh, and please put all information in the question itself, not the comments, please. – Faheem Mitha Oct 11 '14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.