1

I am running Linux Mint 17 Xfce on an HP Elitebook 840 G1 laptop. Up until just now I was using an external monitor, displaying identically the same thing as the built-in laptop display, connected via the VGA port. This worked absolutely fine and as expected.

However, I have accidentally unchecked a tick-box in the System Settings -> Display options, which said something like "use this display". Now the external monitor has vanished from the system settings, seemingly never to return. Of course I have tried restarting the computer and monitor, unplugging the VGA cord etc. Even worse, xrandr now cannot detect a VGA output on my laptop at all! Anyone have a clue what I've done here?

I should add that the display works while the computer is booting up, and also works fine at the login screen. Only once I have tapped in my password does the output to the monitor suddenly stop. I also have Windows installed on another hard drive on the same machine, and the external monitor works fine for that. So there's clearly nothing wrong with the hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.