1

I use a Debian-based Kali Linux box. After I removed Iceweasel (apt-get purge iceweasel), everything was fine. The system worked. I then installed a newer version of iceweasel (apt-get update && apt-get install iceweasel)

The new version on Iceweasel was installed and system worked fine.

Later, I noticed shell telling me "...following (dependencies) are installed but are no longer needed, use apt-get autoremove to remove them). So I did that.

After which I saw my graphics immediately go kind of weird (fonts appeared larger, etc). So I rebooted.

This time it doesn't bring up graphical interface. So I log in from the terminal and then type "x-windows..." which tells me "x-windows.. or x-session-manager failed to start.." etc.

So I guess I broke something in the graphical interface 'x-windows' after the autoremove.

Any help on fixing this so I get my graphical interface back, will be greatly appreciated.

  • So, what did apt-get autoremove remove? Is Iceweasel still installed? – depquid Oct 8 '14 at 20:43
  • Iceweasel is still installed. It removed some dependency that X11 needed I guess. – learnerX Oct 8 '14 at 20:46
  • Paste the X log into your question. – Faheem Mitha Oct 9 '14 at 8:47
  • ... that is usually /var/log/X.*.log. – peterph Oct 9 '14 at 21:29
0

Well, since this happened because of a package removal, the first thing I'd suggest you do is to check which packages got removed lately, and try figure out which of them was relevant for the program that failed to start i.e. 'X-Windows'.

To do so, navigate into /var/log/apt/history.log and check out that file, or, from terminal : cat /var/log/apt/history.log then reinstall that package...

Note: if a GUI session isn't available - on login screen press Ctrl + Alt + F1 / F2 > login > and use the "cat" command...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.