1

I have a one Terabyte hard disk drive (USB3) that suddenly will not mount. My local computer expert (Windows only) had a look at it with his software and said that it is not a hardware problem.

What should I try in order to check or possibly recover it? It does not have SMART capability. I intend to use it for automatic daily backups, and the data on it is the result of my preliminary experiments so is not really needed any more, making my last option to re-format it.

The problem occurred at the end of my attempts to start an automatic daily backup using rsync, which finally worked satisfactorily last evening. However my computer (Linux Fedora 20, with zshell and MATE desktop) would not shut down. This has happened a couple of times before, and it had got there in the end when I left it alone.Yesterday I left it running for more than two hours before I turned it off with the power switch.

I am hoping that I will be able to see what went wrong for the checks. The "Properties" box says that my home directory has "624,332 items, totalling 51.7 GB (some contents unreadable)". Is it possible that I switched off before the data had been transferred?

  • 1
    What type of filesystmem is on the USB3 harddrive? Have you tried to do the appropriate fsck for that volume? Be prepared to go to your backups for restoring the disk. – mdpc Oct 8 '14 at 18:47
  • 1
    Too few details but... It's possible that you switched off your computer when the USB disk still was in use. In such case it's possible it cannot be mounted automatically and you should run fsck on it. Connect the USB disk, wait few second and run 'dmesg' command to find device name assigned by a system. It should be something like /dev/sdb1 or so. Run fsck on this drive to repair possible errors and then reconnect the disk. – Sebastian Piech Oct 8 '14 at 22:10
1

I found the answer here, and followed the advice, as in the following code block. The first line is the recommended command, and the rest is the result from ntfsfix. Now the disk mounts with no problem, with the data apparently intact.

[root@localhost]/home/Harry# ntfsfix /dev/sdb1 
Mounting volume... $MFTMirr does not match $MFT (record 0).
FAILED
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... FAILED
Correcting differences in $MFTMirr record 0...OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... FIXED
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.
[root@localhost]/home/Harry# 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.