2

Environment

Installing drivers

I have installed this card in the NUC. The Bluetooth seems to be detected.

root@marvin:~# rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I have installed various drivers in /lib/firmware/:

following instruction for iwlwifi

# apt-get update && apt-get install firmware-iwlwifi


root@marvin:~# ls -al /lib/firmware/
total 9220
drwxr-xr-x  3 root root   4096 Oct  8 07:47 .
drwxr-xr-x 16 root root   4096 Oct  7 19:06 ..
drwxr-xr-x  2 root root   4096 May 23  2012 hp
-rw-r--r--  1 root root 337520 Jan  5  2013 iwlwifi-1000-5.ucode
-rw-r--r--  1 root root 337572 Jan  5  2013 iwlwifi-100-5.ucode
-rw-r--r--  1 root root 689680 Jan  5  2013 iwlwifi-105-6.ucode
-rw-r--r--  1 root root 701228 Jan  5  2013 iwlwifi-135-6.ucode
-rw-r--r--  1 root root 695876 Jan  5  2013 iwlwifi-2000-6.ucode
-rw-r--r--  1 root root 707392 Jan  5  2013 iwlwifi-2030-6.ucode
-rw-r--r--  1 root root 150100 Jan  5  2013 iwlwifi-3945-2.ucode
-rw-r--r--  1 root root 187972 Jan  5  2013 iwlwifi-4965-2.ucode
-rw-r--r--  1 root root 353240 Jan  5  2013 iwlwifi-5000-2.ucode
-rw-r--r--  1 root root 340696 Jan  5  2013 iwlwifi-5000-5.ucode
-rw-r--r--  1 root root 337400 Jan  5  2013 iwlwifi-5150-2.ucode
-rw-r--r--  1 root root 454608 Jan  5  2013 iwlwifi-6000-4.ucode
-rw-r--r--  1 root root 444128 Jan  5  2013 iwlwifi-6000g2a-5.ucode
-rw-r--r--  1 root root 679436 Jan  5  2013 iwlwifi-6000g2b-6.ucode
-rw-r--r--  1 root root 463692 Jan  5  2013 iwlwifi-6050-4.ucode
-rw-r--r--  1 root root 469780 Jan  5  2013 iwlwifi-6050-5.ucode

but also installing manually using Intel Wireless 7260 drivers

-rw-r--r--  1 root root 683236 Oct  8 07:45 iwlwifi-7260-7.ucode
-rw-r--r--  1 root root 679780 Oct  8 07:47 iwlwifi-7260-8.ucode
-rw-r--r--  1 root root 681464 Oct  8 07:47 iwlwifi-7260-9.ucode

After reboot, the wireless adapter is still not detected.

How can I make sure that my iwlwifi drivers are loaded?

dmesg doesn't show any errors, iwlwifi doesn't show up either (?). I figured I should see an entry for iwlwifi after copying the driver in /lib/firmware


dmesg after resolution

# dmesg | grep wifi
[    2.855945] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[    2.856117] iwlwifi 0000:02:00.0: irq 43 for MSI/MSI-X
[    2.860244] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-7260-9.ucode
[    2.860529] iwlwifi 0000:02:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
[    2.876312] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    2.876893] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    2.877157] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    4.993291] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    4.993523] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
  • Check the dmesg output, maybe there are error messages in there that might help to diagnose the issue. – Martin von Wittich Oct 8 '14 at 12:30
  • I don't see any issues there. I will upload the output of dmesg to the question. I am wondering is there is some kind of kernel config. I have been reading here that there is some rules to load firmware ... but this is really totally new to me. – zabumba Oct 8 '14 at 12:36
  • I can upload the output of dmesg, it's too long, but there isn't any errors in there and it doesn't seem to be loading the iwlwifi drivers either ... may be that's the issue (??) – zabumba Oct 8 '14 at 12:45
  • 1
    Hmm, maybe your kernel is too old. wireless.kernel.org/en/users/Drivers/iwlwifi says "Intel® Wireless 7260 (3.10)", so you'll need at least Linux 3.10. Set up Debian backports, and install a newer kernel: aptitude -t wheezy-backports install linux-image-amd64. – Martin von Wittich Oct 8 '14 at 13:10
  • 1
    Arghh you are right! I totally missed that, although I had checked before. So that Worked! You may want to copy your comment into an Answer. I will accept it! thx mate. – zabumba Oct 8 '14 at 13:22
4
  • Debian 3.2.60-1+deb7u3 x86_64 GNU/Linux
  • 867Mbps 802.11ac Intel 7260 card, Dual band 5GHz + 2.4GHz Wireless 2x2 AC + Bluetooth4.0

Your kernel is too old. http://wireless.kernel.org/en/users/Drivers/iwlwifi says "Intel® Wireless 7260 (3.10)", so you'll need at least Linux 3.10.

Set up Debian backports, and install a newer kernel:

aptitude -t wheezy-backports install linux-image-amd64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.