0

Environment

  • Intel Next Computing Unit aka NUC DC3217IYE
  • 120GB SSD drive
  • 4 GB
  • unetbootin tool
  • debian-7.6.0-amd64-netinst.iso

My objective is to install Debian on the NUC

What have done so far

  • Prepared Debian USB drive with Debian image using unetbootin
  • Inserted in USB drive with Debian port onto the NUC
  • Installed Debian without a sweat, rebooted ... FAIL
  • Updated NUC with the latest BIOS from Intel website ... still FAILING

After reboot I persistently have:

Media test failure, check cable
Exiting Intel boot agent
Reboot and select proper boot device
or insert boot media in selected boot device

Looks like it's trying to boot from the network, so I disabled that from the BIOS and tried again and now I have

Reboot and select proper boot device
or insert boot media in selected boot device

This is a recurrent problem, I have read lots about it to no avail.

Note: As suggested in another thread, I have also tried to set the fan to 'cool' in BIOS. Without results. Apparently this helped for some NUC models.

Any recommendation is most welcome.

6
  • Why are you messing with your fan when the problem is the SSD drive?
    – eyoung100
    Commented Oct 7, 2014 at 16:52
  • That was suggested in another thread. Apparently it was causing the media failure. But that didn't help for my case. And since that seems so relevant to you, I will find the source. BUT Instead I'd like to real help. You comment sounds a little patronizing.
    – zabumba
    Commented Oct 7, 2014 at 17:04
  • It isn't patronizing, it's truthful. Your Error Indicates 1 of 3 Things. 1. Your BIOS is misconfigured and you have no Boot Drive Set. 2. The Debian Install Disk cannot find the new Disk either. This may be caused by #1 or maybe you forgot to connect a power cable etc. 3. The Disk is Empty. The Network Cable is unplugged so the PXE Boot was failing, but once again, that has nothing to do with the root error. Make sure your BIOS is set to boot from USB, so that the USB boots before the empty SSD.
    – eyoung100
    Commented Oct 7, 2014 at 17:15
  • #1 boot drive is set in BIOS #2 the Debian dongle installed perfectly on the 120GB SSD drive i.e. the drive is not empty. It's NUC issue and the messages are misleading. So despite your correct assessment based on the error messages, I must say that I think that there is a little more to it.
    – zabumba
    Commented Oct 7, 2014 at 17:23
  • 1
    Read the link you gave me. Page 1, regarding the name of the EFI boot file. There is your issue. Rename the file as they suggest and report back.
    – eyoung100
    Commented Oct 7, 2014 at 17:29

1 Answer 1

0

Resolution in this article

In my particular case, I had EFI/debian/grubx64.efi

I created the 'BOOT' folder and cp grubx64.efi ./BOOT/bootx64.efi

After reboot I was able to select Linux from GRUB

1
  • 1
    The issue is that the Intel UEFI setup utility it "Boot" menu isn't configured with you EFI boot file. You can fix this from a modern Linux LiveCD, then starting the terminal and run the corresponding efibootmgr command. For example when your EFI folder is located on partition 1: efibootmgr -c -p 1 -L 'Grub64' -l '\EFI\BOOT\grubx64.efi'. When adapting this command (and copying your kernel to the EFI boot folder) you can even UEFI boot directly to your kernel without Grub.
    – Pro Backup
    Commented Oct 7, 2014 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .