I'm trying to install KDevelop on my machine, How do I solve this issue

Steps followed

cd /usr/ports/devel/kdevelop-kde4
make install clean


# make install clean 
===>  Found saved configuration for kdevelop-4.5.2
===>   kdevelop-4.5.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by kdevelop-4.5.2 for building
===>  Extracting for kdevelop-4.5.2
=> SHA256 Checksum OK for KDE/kdevelop-4.5.2.tar.xz.
===>  Patching for kdevelop-4.5.2
===>  Applying FreeBSD patches for kdevelop-4.5.2
/usr/bin/sed -i.bak -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d'  /usr/ports/devel/kdevelop-kde4/work/kdevelop-4.5.2/app/CMakeLists.txt
===>   kdevelop-4.5.2 depends on file: /usr/local/bin/cmake - not found
===>    Verifying install for /usr/local/bin/cmake in /usr/ports/devel/cmake
===>  License BSD accepted by the user
===>   cmake- depends on file: /usr/local/sbin/pkg - found
=> cmake- doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://downloads.cmake.org/files/v2.8/cmake-
fetch: http://downloads.cmake.org/files/v2.8/cmake- Moved Temporarily
=> Attempting to fetch ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/cmake-
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/cmake- File unavailable (e.g., file not found, no access)
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

make[2]: stopped in /usr/ports/devel/cmake
*** Error code 1

make[1]: stopped in /usr/ports/devel/kdevelop-kde4
*** Error code 1

make: stopped in /usr/ports/devel/kdevelop-kde4




# uname -a
FreeBSD bhathiyaBSD 10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789: Thu Jan 16 22:34:59 UTC 2014     [email protected]:/usr/obj/usr/src/sys/GENERIC  amd64

1 Answer 1


Your ports tree is out of date. cmake is currently at version 3.0.2, and kdevelop-kde4 is at 4.6. In addition, FreeBSD now keeps distfiles at http://distcache.freebsd.org/ports-distfiles. If you have set MASTER_SITE_BACKUP in /etc/make.conf, remove it or change it to http://distcache.FreeBSD.org/ports-distfiles/${DIST_SUBDIR}/ (the default value).

You need to bring your ports tree up to date somehow. The way you do this depends on how you installed it in the first place. If you simply selected it as an installation option when you installed the system, you need to delete it, then use portsnap fetch extract to retrieve the latest version. If you used portsnap to install it, you can simply use portsnap fetch update to bring it up to date.

  • 1
    Yes - rm -rf /usr/ports will do the trick. portsnap will rebuild the tree for you.
    – D_Bye
    Oct 7, 2014 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .