2

I've got Windows 7, Ubuntu and FreeBSD installed on one separate partitions on one harddrive. When I boot, I only have the option to choose Ubuntu or Windows 7. After a successful FreeBSD install, it does now show in the GRUB.

I've loaded into both Ubuntu and Windows and they're in fact labeled correctly and pointing to the correct partition and displaying the correct operating system without any flaws or issues.

Here is the data I have accumulated so far during this process.

1.) OPERATING SYSTEM PROGRESSION

I first started with Windows 7. Then as a programmer I wanted to learn Linux, so I added Ubuntu. Within the installation of Ubuntu, it allowed me to "Change" my main partition without having to go into Computer/Disc Management in Administrative Tools in Windows. So that was convenient I changed my partition and re-sized it on the spot to allow room for Ubuntu. It worked great and before you knew it I was typing and memorizing terminal command lines. It felt great. A lot of things I do like with GitHub and other SSH routines make much clearer sense to me now.

So, feeling that good vibe of feelings, I thought how cool would it be to be able to relate to some of those really old school database / IT guys while having a cigarette or coffee of whatever. Let's give Unix a try. Why not right?

2.) BOOT OPTIONS BEFORE UBUNTU AND AFTER UBUNTU

In the past if I've had two versions of windows, E.G. Windows XP and Widows 7 installed, I'd have an option to "Load Previous Version of Windows" or load "Windows 7" with a 30 second countdown before it chose the first choice.

Now after installing Ubuntu, I guess I'm now experiencing the "GRUB?" It shows loading Ubuntu first, Advanced Ubuntu options, Memtest and Memtest(86) and lastly, Windows 7 at the bottom with a, I believe, 10 second count down.

3.) HOW I ADDED MY FREEBSD PARTITION

I was going to boot into Windows 7 and use the Computer/Disk Management and remove some space from my Windows partition, but I only had 20GB left on the Windows partition since I gave my Ubuntu partition half of my hard drive (doh.) When I tried to split the Ubuntu partition, everything related to splitting, expanding, or anything to that regard was grayed out. Then I remembered the options the Ubuntu installation disc gave me. The "modify" option. So I did just that. I now had access to change the Ubuntu partition within the Ubuntu install disc. I modified it, and split it in half, giving my partition allocated for FreeBSD 50 sweet GBs.

4.) WHAT MAY BE CAUSING THE ISSUE? I NEED HELP HERE.

So when I modified the partition in the Ubuntu installer (which I exited after modifying the partition,) I never formatted the partition. Unless the Ubuntu installer gives a default filing system during modification, I don't know how it was formatted. When I installed FreeBSD onto it, it seemed to be happy and installed fine. I loaded up network drivers, added my wifi password. Created root accounts and non-root accounts and a few other things.

5.) CONCLUSION

My bootloader, which is now covered over to the new GRUB, does not list FreeBSD or any indication that I have another partition with another operating system on it and in order in having any shot with bonding with the Unix guys, I am going to need your help. Thanks for your expertise.

  • I don't understand, what's "now" showing? FreeBDS? Windows? Anything else? – Braiam Oct 7 '14 at 13:48
  • It's showing Ubuntu and Windows 7 and they both work properly. Just don't know how to access my FreeBSD :( I updated my question with a lot more clarity too since you posted last. – tommydevs Oct 8 '14 at 0:18
2

FreeBSD's boot loader isn't very good at multi-booting apparently. In which case, it's probably overwritten Ubuntu's boot loader (grub2) with it's own.

A possible solution would be to boot into FreeBSD and configure it to install it's boot loader on the slice(partition) where FreeBSD is installed (as opposed to the MBR).

Next boot into the Ubuntu CD/DVD and attempt to re-install grub2 to the MBR. It should recognise the FreeBSD boot loader on the slice and add an entry for booting FreeBSD as well as Ubuntu and Windows.

Note: I don't have FreeBSD in order to verify this.

  • I edited my question since it's on hold for being unclear. Maybe this will help you answer me better? But after reading this, I booted into both partitions and they pointed properly and loaded up both operating systems perfectly so I don't think there's any pointer errors, just a lack of one pointer allowing me to access my new operating system. – tommydevs Oct 7 '14 at 21:51
  • It may be related to this question. – garethTheRed Oct 8 '14 at 5:34
  • Thanks Red. That question is exactly the problem I'm having except for he knows just a little bit more about what's going on than I do which I think helped people answer his question. I will read through it. It looks like there are several answers. I'll post here if I find a solution. Thanks again, Red. – tommydevs Oct 8 '14 at 6:09
0

Like I said in a post one before ... booting into FreeBSD is not a problem with Grub2. You only specify your root partition (of the FreeBSD installation) and then you go with kfreebsd /boot/loader. When it disappears after an upgrade of a kernel for example on your linux installatin, that is not a problem either. Write it to the custom section under /etc/grub.d/ where it creates the configuration every once a while from.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.