3

There it is, once more:

The process for the file protocol died unexpectedly

in red! Dolphin doesn't show files, except of the current directory before the death. Closing every instance and restarting doesn't help. Starting from command-line shows:

QSqlQuery::prepare: database not open

when the error is displayed. And when clicking on some favorites:

QSqlDatabasePrivate::database: unable to open database: "unable to open database file Error opening database" 
QSqlQuery::prepare: database not open

It works for ssh-fs links (fish as protocol)... thats suprising.

I hope it's not related to the nfs directories... but that would help: what is the reason for this crash? Is it possible without reboot / logout and -in to get dolphin running again?

Nautilus works fine, mc also. I'm running Debian Jessie (Testing) with Gnome 3. (And I don't like nautilus :)

1
  • Hmm... got this out the blue with "Trying to convert empty KLocalizedString to QString. Cannot creat accessible child interface for object: PlacesView(0xBLAH) index: 28 The process for the trash protocol died unexpectedly." Sounds like KDE levels of stable. Dec 7 '16 at 16:23
2

This just happened to me in awesomewm after updating some KDE packages. When launching dolphin from a terminal, I got:

kf5.kio.core: "The process for the tags protocol died unexpectedly."
kf5.kio.core: "The process for the trash protocol died unexpectedly."

and nothing was visible in Dolphin (other than the same red error message as OP).

The solution seemed to be killing kdeinit5.

3
  • Is killing a process really a solution? Is this something that you needed to do just the once after the upgrade, or something you need to keep doing to allow KDE to work properly?
    – roaima
    Apr 16 '20 at 14:12
  • 1
    I agree, it's not a "solution" in that it doesn't identify/fix whatever the actual bug was. But it's better than restarting your computer, which is all I found for advice elsewhere. And no, I've used Dolphin (outside of KDE) for probably 10 years and only needed to do this once.
    – alex
    Apr 17 '20 at 17:04
  • Whoa, three years later and the same solution just worked for me - no matter that I've rebooted countless times in the meantime, or the fact that I've upgraded lots of packages on my system, killing kdeinit5 fixed it. Strange.
    – Tomáš M.
    Nov 26 '20 at 15:03
0

Well....it might be time to restore the database files from backups, presuming you do periodically make them.

A couple of other thought include package corruption, you could reinstall the old package over the current one.

Second, what about a compromised server?

1
  • um... no... what? I need to say, this problem happened already some time ago and it was gone for some weeks. So no broken database, which needs to be restored... Since it's a local problem, no compromise needs to be assumed.
    – PythoNic
    Oct 7 '14 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.