1

I am following the mono installation tutorial. First I add repo to list, then I import key and finally I try to update the repos.

On last step I get error:

W: Failed to fetch http://download.mono-project.com/repo/debian/dists/wheezy/main/binary-amd64/Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried to fix this by running rm -rf /var/lib/apt/lists/* but the error remains.

Can you help me understand why this error happens and if possible a resolution/workaround? I would prefer not to compile from source nor to use the version in official repository.

I installed debian in a VM using debian-7.6.0-amd64-DVD-1.iso

2

2 days ago It was working, today I am also having same problem.

But I think hash file is incorrect @ mono-project site.

If you check file size or create hash file for Packages file you can see that it is not same as hash file.

binaries

http://origin-download.mono-project.com/repo/debian/dists/wheezy/main/binary-amd64/

file size and hash list of packages:

http://origin-download.mono-project.com/repo/debian/dists/wheezy/Release

Edit: they updated checksum file and also binaries couple of minutes ago and they match now. Try again, it might work now.

1

Nesim's answer prompted me to ask on a mono-related mailing list. The answer I got was:

Wait a few hours. This is caused by the download site being behind a CDN, and the caches for Release and Packages.gz being mismatched. It'll clear itself up within a few hours.

After ~12 hours it has not fixed itself, but a new error arose:

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.mono-project.com wheezy Release: The following signatures were invalid: BADSIG A6A19B38D3D831EF Xamarin Public Jenkins (auto-signing) <releng@xamarin.com>

W: Failed to fetch http://download.mono-project.com/repo/debian/dists/wheezy/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.

After 14 hours the repository was parsed successfully and the problem has been resolved.

  • Mine resolved too but now I am getting: The following packages have unmet dependencies: mono-fpm-server : Depends: mono-xsp4-base (>= 3.8) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Nesim Razon Oct 7 '14 at 9:41
  • Try to force installation of mono-xsp4-base >= 3.8 first? – Jure Špik Oct 7 '14 at 10:07
  • Yep, I tried that, than It gave same error for another monolib, I tried for that this time and problem completely solved. – Nesim Razon Oct 7 '14 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.