2

I have a Fedora 20 KDE on a 512 mini SSD disk. Yesterday I unfortunately downloaded many rar-files into my /root partition and ran this command afterwards: unrar x *.rar. So what happened? My PC got stuck and I could not do anything more so I pushed the power off button as hardly as I can. After I started it again my Fedora stuck at this part
Failed to write pack file. So my thoughts are that my root partition is full.

My question know how to get this files deleted?

What I tried:
I downloaded a Fedora 20 Live Image and copied into a USB stick. After that I tried to boot from the USB stick to get into the rescue mode. But I don't have a submenu under Troubleshooting which contains something like rescue mode. No problem I thought because I saw that someone said you have to run Linux rescue from the grub. I did that, but I got another error message that it could not find a kernel named Linux. Fine so I googled more and more. I saw a post that the Fedora Live CD does not have a rescue mode. I have to start the Live CD and mount my existing fedora OS. But this did not help either.

So does anybody know what to do now?

  • 1
    Why didn't mounting the drive help? If you mounted the drive as root you will be able to erase the files you unrared. – YoMismo Oct 6 '14 at 8:31
  • 1
    You can use any live rescue cd, it doesn't have to be Fedora. /root isn't usually a partition (though it could be), likely a directory on /. You need to know which filesystem to mount, then mount it and clean it. SysRescueCD is fairly stable and robust. – bsd Oct 6 '14 at 8:42
1

There's no need to go into a special rescue mode. Boot the Live image, and instead of running the installer, fire up a terminal and use that to repair your existing system.

0

download boot.iso

http://mirrors.eu.kernel.org/fedora/releases/20/Fedora/x86_64/os/images/boot.iso or http://mirrors.eu.kernel.org/fedora/releases/20/Fedora/i386/os/images/boot.iso

we can put boot.iso on a usb stick , in same way that we put live images, describe in USB Booting : usb must be on vfat or else format usb with:

# mkfs.vfat /dev/sdb1.

# /usr/bin/livecd-iso-to-disk boot.iso /dev/sdb1

also you may test is USB boot with :

qemu-system-i386 -hda /dev/sdb -boot a

my references:

http://www.serjux.com/freedos_boot/Create-a-bootable-rescue.txt

http://www.serjux.com/freedos_boot/Createabootableusbandcheckifboots.txt at the end of the page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.