1

I'm using vim and have installed Pathogen and vim-fugative, but when editing a file under source control on github.com I use the command :Gbrowse and nothing happens.

I've tried most of the advice I can find on the web about setting up particular browsers on the web but none of it worked. So I tried looking at the script that was trying to start up the browser (so I have removed references about the browser from .gitconfig).

So I found the shell script: git-web--browse and modified it to generate logging statements to a log file (to see if I could work out what was going on).

But when I use :Gbrowse I get no logging statements (so it looks like vim is not even calling this script).

Any ideas what I'm doing wrong?

Info

System Mac OS X (10.9.5)

$ uname -a
Darwin Martins-MacBook-Pro.local 13.4.0 Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64

$ which vim
/usr/bin/vim

$ vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Aug 24 2013 18:58:47)
Compiled by root@apple.com
Normal version without GUI.  Features included (+) or not (-):
-arabic +autocmd -balloon_eval -browse +builtin_terms +byte_offset +cindent
-clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
-conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con +diff +digraphs
-dnd -ebcdic -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path
+find_in_path +float +folding -footer +fork() -gettext -hangul_input +iconv
+insert_expand +jumplist -keymap -langmap +libcall +linebreak +lispindent
+listcmds +localmap -lua +menu +mksession +modify_fname +mouse -mouseshape
-mouse_dec -mouse_gpm -mouse_jsbterm -mouse_netterm -mouse_sysmouse
+mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg -osfiletype
+path_extra -perl +persistent_undo +postscript +printer -profile +python/dyn
-python3 +quickfix +reltime -rightleft +ruby/dyn +scrollbind +signs
+smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
+tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title
 -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
+vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim -xsmp
 -xterm_clipboard -xterm_save
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -D_FORTIFY_SOURCE=0 -Iproto -DHAVE_CONFIG_H -arch i386 -arch x86_64 -g -Os -pipe
Linking: gcc -arch i386 -arch x86_64 -o vim -lncurses

I have installed Pathogen and, in ~/.vimrc:

 19 ¬
 20 ¬
 21 execute pathogen#infect()¬

In ~/.vim/bundle:

$ ls -l ~/.vim/bundle/
total 0
drwxr-xr-x  13 Loki  staff  442 Oct  4 15:18 gundo.vim
drwxr-xr-x   9 Loki  staff  306 Oct  4 14:08 tabular
drwxr-xr-x   8 Loki  staff  272 Oct 26  2012 vim-colors-solarized
drwxr-xr-x   8 Loki  staff  272 Oct  4 17:59 vim-fugitive
drwxr-xr-x   7 Loki  staff  238 Oct  4 13:43 vim-unimpaired
1
1

This seems to be a problem with the version of vim that comes with OSX.

You're better off installing a newer version of vim from homebrew

brew install vim

Beware if you're using RVM though as Ruby plugins might segfault if you compile them against anything other than the system Ruby. Best this if you use RVM.

rvm use system; brew install vim

You should also find that the homebrew vim has useful features like +clipboard support etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.