5

I have Debian Squeeze and want to create USB flash drive for install Ubuntu 11.04. I've already tried many ways:

  1. boot.img.gz + mini.iso at drive's root + syslinux = installer "couldn't found installer iso"
  2. boot.img.gz + extract mini.iso to drive's root + syslinux + replace original syslinux.cfg by isolinux.cfg from mini.iso = "invalid keyword in syslinux.cfg" error
  3. extract normal CD iso to drive's root + grub = black screen with blinking cursor
  4. UnetBootIn from repos + normal CD iso = screen with many vertical color lines

At the moment I'm waiting until usb-creator.exe (launched from Windows) finish. Could you explain the right way to create Ubuntu USB-installer from Debian?

  • 1
    Did you verify the ISOs for Ubuntu that you used were fully 100% downloaded and valid by checking the hashes for your downloaded files off of the hashes of the original ISOs (from Ubuntu's site)? – Thomas Ward Jul 1 '11 at 14:21
  • Yep, md5 sums are equal. – Kirill Jul 1 '11 at 14:29
  • 1
    I was recommended by the Ubuntu people that you theoretically could use dd via the command line to get it to work... then all you'd need to do is flag the drive as bootable... but i forget the steps that were outlined... if I can find the instructions, i'll link them here (and thus point you to the correct answer) – Thomas Ward Jul 1 '11 at 14:36
  • 1
    Ooops i lied, that was for an older distro (ancient xD). According to my research, Ubuntu ISOs are not able to be dd'd to a device, and that UNetBootin is the most widely accepted install method, but it seems it didnt work for you. Did you try unetbootin by downloading it separately (NOT from repos)? – Thomas Ward Jul 1 '11 at 14:43
  • I'll try it tomorrow. Just now I've tried to boot qemu from USB created by UnetBootIn: qemu /deb/sdd1 And it says: ''Booting from Hard Disk ... Boot error''. so the problem is not in the computer to which I am going to install Ubuntu. – Kirill Jul 1 '11 at 16:19
2

I did it like this:

$ wget http://archive.ubuntu.com/ubuntu/dists/karmic/main/\
installer-i386/current/images/netboot/boot.img.gz

Or to choose current Ubuntu Natty and amd64 architecture:

$ wget http://archive.ubuntu.com/ubuntu/dists/natty/main/\
installer-amd64/current/images/netboot/boot.img.gz

# zcat boot.img.gz > /dev/sdc
# eject /dev/sdc

On an old Thinkpad R40 the bios USB boot support was not that great - the bios wanted a mbr, thus I created the USB stick like this:

# cfdisk /dev/sdc
only one primary partition
file system type -> 06
bootable
write
# lilo -M /dev/sdc
# zcat boot.img.gz > /dev/sdc1
# eject /dev/sdc

Note that this method uses the text-based network installer.

Of course, you have to adjust the USB device name (/dev/sdc above), the Distribution name (Karmic is not 11.04) and architecture (x86 vs. amd64).

  • I've also tried boot.img.gz. Is it enough to perform network install? No additional ISO needed? And is there a way to use WiFi during this installation or only variant is to use wired connection? – Kirill Jul 2 '11 at 4:34
  • 1
    @Silver_Ghost, yes, it is enough to perform network install. That is the appeal of this method - (plus nowadays network access is often faster than cdrom access). I am not sure about wireless support (never tried it) - using the wire is of course the best supported way - for wireless see e.g. geofft.mit.edu/blog/post/109 - but it may get complicated when you want to use WPA, have exotic wireless hardware etc. – maxschlepzig Jul 2 '11 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.