1

When I run tmux in cygwin command line I get the error:

$ tmux
      0 [main] tmux 6688 C:\cygwin64\bin\tmux.exe: *** fatal error - NtCreateEvent(lock): 0xC0000077
Hangup

I tried to reinstall tmux 1.9a-1 using cygwin setup, also installed tmux-debuginfo but to no avail.
My os: Windows 7 x64
uname -a: CYGWIN_NT-6.1 Heaven 1.7.32(0.274/5/3) 2014-08-13 23:06 x86_64 Cygwin

0

2 Answers 2

2

This question appeared closely related to another one previously posted, which hinted at the possible culprit: the 64-bit version of Cygwin.

Indeed it has helped a countless number of users to install the 32bit version of Cygwin, which - in most of cases - made tmux and other applications work.

Oddly enough, a sort of "derivative" of this bug was reported back in 2011 already: http://comments.gmane.org/gmane.os.cygwin/128288 .

Nevertheless, this IS a bug and must be properly fixed in the 64-bit version of Cygwin. I hope for all users this will have happened by the end of the new year.

0

A different cause of the same problem can also occur.

.babun\cygwin\bin\tmux.exe: *** fatal error - NtCreateEvent(lock): 0xC0000058

Your anti-virus might stop the program from running.

The solution is to exclude the program from being blocked. (With bitdefender its Show->modules->Anti Virus->Exclusions->Excluded Processes )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .