1

I use a Hungarian keyboard layout. To type a less-than sign, I have to press: AltGr+í.

By default, the Emacs Meta key is set to Alt, so I think I would have to press all of AltGr, Alt and í at once.
But for some reason it seems that AltGr and Alt cancel out each other, so this does nothing. I've tried it in terminal and under X too. AltGr+í sends a <, but when I pressed Alt and AltGr, the í key didn't send a new KeyPress event.

I'm using Lubuntu 14.04.1 LTS. I've selected the keyboard layout when I was installing the system using the graphical interface.

  • Are you running Emacs in a terminal or under X? What is your keyboard layout (nationality and any extra options)? Run the utility xev in a terminal and press AltGr+í and AltGr+Alt+í, what KeyPress eveents are sent? – Gilles 'SO- stop being evil' Oct 4 '14 at 0:09
  • @Gilles I've tried it in terminal and under X too. The keyboard layout is hu. AltGr+í sends a "<", but when I pressed Alt and AltGr, the í key didn't send a new KeyPress event. – user Oct 4 '14 at 0:39
  • How did you select the Hungarian keyboard? (Different variants have different tweaks regarding modifiers.) What distribution are you using? – Gilles 'SO- stop being evil' Oct 4 '14 at 0:43
  • I'm using Lubuntu 14.04.1 LTS. I've selected the keyboard layout when I was installing the system using the graphical interface. – user Oct 4 '14 at 0:51
  • You should be able to use Esc instead of Alt fir emacs's M key. – terdon Oct 4 '14 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.