1

I tried CheckInstall to track installation of package on Debian, but it fails to install it. Installation follows the typical configure/make process

$ autoconf
$ ./configure
$ make
$ make install

Therefore I just replaced $ sudo make install with $ sudo checkinstall. When I run checkinstall it start process of creating a package and start asking a series of questions. And here is where I made a mistake, I just wanted to build a package to add to my own system, not for distributing the finished package, so I just tried to accept the default answers, enter, etc.

I didn't specified "package version" (which is senseless for me), it started doing normal, but in the end CheckInstall complained that package version is missing, etc and installation failed.

It left the various orphaned files in the package folder: how to clean this, and how to proceed with this? Where Linux put files when installation fails: does it do same as Windows that store installation in temporary files and clean them out, so files is not remain in the system, or Linux keep these files and scatters them over the system?

1 Answer 1

1

If checkinstall failed probably the package isn't installed, no need to remove, eventually try sudo dpkg -r <package-name>, and you can safely remove with rm intermediate files left in the directory.

The version is important for dpkg/apt so you must use one, even a fake, if tomorrow a package with the same name enter the distro, the one with the newer version will be installed.

7
  • I tried to remove with dpkg -r and it return the package not installed.
    – Lexx Luxx
    Oct 3, 2014 at 15:41
  • In dpkg we trust, so wasn't installed :-)
    – Alex
    Oct 3, 2014 at 15:43
  • So, just manually to remove CheckInstall files from package directory?
    – Lexx Luxx
    Oct 3, 2014 at 15:45
  • Yes that's it, is just some temporary/cache file checkinstall leave around, I'm sure checkinstall use dpkg -i to install the generated .deb, if dpkg say it isn't installed there should be nothing else left around. Curiosity, what the package you're trying to install?
    – Alex
    Oct 3, 2014 at 15:50
  • that was binwalk.
    – Lexx Luxx
    Oct 3, 2014 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .