I'm trying to install a Debian package from source (via git). I downloaded the package, changed to the package’s directory and ran ./configure command but it returned bash: ./configure: No such file or directory. What can be the problem? A configure.ac file is located in the program folder.

sudo make install
  • What Package are you trying to install?? – eyoung100 Oct 2 '14 at 23:17
  • @eyoung100 binwalk – triwo Oct 2 '14 at 23:26
  • See Install Binwalk Without Graphing. Of course if you need the graphing dont skip make deps. If it helps, just upvote me, and I'll know it was you :) – eyoung100 Oct 3 '14 at 1:52

If the file is called configure.ac,

do $> autoconf

Depends: M4, Automake

If you're not sure what to do,

try $> cat readme

They must mean that you use "autoconf" to generate an executable "configure" file.

So the order is:

$> autoconf
$> ./configure
$> make
$> make install
| improve this answer | |
  • You mean use autoconf before ./configure? – triwo Oct 2 '14 at 23:39
  • You use autoconf instead of make when you have a .ac file. It replaces ./configure. – Tyler Maginnis Oct 2 '14 at 23:48
  • so, ./configure and make commands both skipped, only autoconf, then make install? – triwo Oct 2 '14 at 23:54
  • 1
    It's autoconf, then ./configure, then make, then make install. Doesn't your package have a READ-ME? It's $> autoconf $> ./configure $> automake... I think that's how it goes. It's been a while since I've installed an autoconf package. – Tyler Maginnis Oct 2 '14 at 23:55
  • Interesting. Manual says installation "follows the typical configure/make process" I've specified above. Autoconf is not not mentioned. – triwo Oct 3 '14 at 0:06

The failsafe for generating a configure script is autoreconf -i, which not only takes care of calling autoconf itself, but also a host of other tools that may be needed.

| improve this answer | |
  • autoreconf: configure.ac' or configure.in' is required. – Dr.jacky Jul 26 '15 at 4:40
  • 1
    @Mr.Hyde Well, obviously it only works for projects that use autoconf. – o11c Jul 26 '15 at 16:01
  • I had to install libtool before this would work. – user3338098 Oct 16 '18 at 22:04
  • @user3338098 If you've installed your distro's "all important build tools" package (Debian/Ubuntu apt-get install build-essential), it should include that already I think? – o11c Oct 17 '18 at 0:57
  • @o11c i'm on a customized centos 7.5, build-essential isn't available in any obvious direct sense. – user3338098 Oct 17 '18 at 16:51

It's just problem with permissions Run chmod +x ./configure Should work

| improve this answer | |
  • No, attempting to run a shell script which is non-executable produces “Permission denied”, not “No such file or directory”. – Stephen Kitt Jun 30 at 7:14
  • It worked for me! – Navneet Khandelwal Jul 3 at 4:20
  • Of course it worked for you; but you didn’t have the same problem as the author of the question. – Stephen Kitt Jul 3 at 4:58

I found this in the readme on the GitLab:

cd <build_directory>
cmake -DCMAKE_INSTALL_PREFIX=<install_dir> <source_code_dir>
cmake --build . --config RelWithDebInfo
cmake --build . --target install

This is what we're supposed to do! :D So far, it is working for me!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.